AMD Catalyst Control Centre not showing GPU settings (Only CPU & power)

Aug 16, 2018
2
0
10
0
OS: Win7 home premium sp1 (64-bit)
CPU: AMD FX(tm) 4170 Quad core 4.2GHz
Motherboard: ASUS M5A78L-M/USB3
Ram: 8GB (Adata Gaming Series 4gb x2)
SSD/HDD: Seagate Baraccuda SATAII 500gb HDD
GPU: Sapphire Radeon HD 6950 2GB
PSU: Corsair VS 650w

I thought I had an issue with my graphics cards, as it was constantly crashing. I uninstalled it and removed it from my desktop PC. Turns out to be an issue with my hard drive so I reinstalled everything and the hardware seems to working just fine but the AMD driver (Catalyst Control Centre) isn't showing me the settings I had before. There's only power management and CPU settings.... and nothing related to the GPU.

I've searched around online and came up short, mainly because lots of issues seem to be with win 8/10. Here's the stuff I've tried so far:

- Made sure I'm in advanced view

- Checked windows update before/after all the below steps

- Downloaded the specific driver from AMDs website and reinstalled (Tried the crimson beta as well)

- Checked device manager (No warning signs, the VGA adapter is installed and "The device is working correctly" is also showing in properties)

- Tried running driver .exe in Win7 compatability mode

- Tried a clean driver install using these steps from another thread several times:

___________________________________________________________________

If you run into issues after trying to update your AMD drivers normally, try a 'clean install'.

To perform a 'clean install' of AMD graphics drivers:

1. Download and save the correct AMD driver. Do not use "automatically detect and install". Download Drivers

2. Download and save DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

3. Disable All anti-virus/anti-malware/anti-anything

4. Delete the contents of the C:/AMD folder of all previous drivers

[strike]5. Win10 users..take the necessary steps to prevent/delay Microsoft automatically changing/installing graphics drivers using one of these methods > Windows 10 Forums[/strike]

6. Win7 and Win8.1 users read note*

Uninstall the old drivers using the computer control panel > 'uninstall a program' > choose AMD and uninstall everything:

Reboot into SAFE MODE > run DDU and let it restart your computer. Install the new drivers. Reboot.

** Windows 7 and Windows 8.1 must be fully updated before attempting to install any AMD driver. All 'critical', 'recommended', and 'optional' (no language packs,etc) updates as well as any Service Packs (SP) must be installed before any attempt to install graphics drivers. If you do not get this message .... keep installing until you do:

___________________________________________________________________


Now I'm pretty lost for what else to try, anyone have any ideas?
 

Lutfij

Titan
Moderator
1| AMD HD 6900 is a series number. What is the exact model for your GPU? A link to the GPU would be helpful.
2| Have you tried working with older drivers, pre-Crimson? I'm yet working with drivers released back in 2015 for my HD 6870.
3| On second thoughts, please pass on your full system's specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
 
Aug 16, 2018
2
0
10
0
I edited the original post with the full specs :) Yeah I've been using pre-crimson drivers but have tried the beta but there's no difference. Here's the ones I've tried:

15.7.1 WHQL
Crimson Edition 16.2.1 Beta

After finding the specific model for my gpu, I tried the 14.12 Omega driver from the link to my GPU above. Still no luck.
 

ASK THE COMMUNITY