Question AMD CPU not detected after bios update

Jul 20, 2019
3
0
10
0
I have update ma config to a New ryzen 3600x in a B450 aorus M motherboard, but as u know, 400 series need a bios update to recognize 3000 cpu. I dont have any other amd cpu , so i get another one: an a8 9600.
At the beginning motherboard had f5 version, it detected the a8 cpu and i downloaded f32 version from gigabyte.
(As was suggested to install f32 before f40)
After updating the bios motherboard doesn’t recognize anything, even the a8 cpu it recognized a few minutes earlier. What happened?arent al update compatibile with all earlier version? What should i do?
 

Rodrigodrt

Reputable
Nov 21, 2014
411
24
4,915
34
bios updates should be retrocompatible with anything, are you sure the process went well without any issues? fail bios updates could brick the cmos and welp, render your mobo useless until you find another way to reflash it.

remove the battery and wait a good 30 seconds for everything to reset to the default settings, then try again.
 
Jul 20, 2019
3
0
10
0
bios updates should be retrocompatible with anything, are you sure the process went well without any issues? fail bios updates could brick the cmos and welp, render your mobo useless until you find another way to reflash it.

remove the battery and wait a good 30 seconds for everything to reset to the default settings, then try again.
I think installation completed succesfully, it reached 100% then system was rebooted and problem appeard.
Tried to remove battery but not worked
 

Rodrigodrt

Reputable
Nov 21, 2014
411
24
4,915
34
I think installation completed succesfully, it reached 100% then system was rebooted and problem appeard.
Tried to remove battery but not worked
boi... once upon i time i had a motherboard that completely would not respond to my processor, then i swapped it with a friends and it booted, then i put my original back and it started working all nicelly again.

anyways try swapping the ram slots, leave just one and try different slots, unplug any CD/SSD/HDD, leave the mobo with only the necessary to show video... wonder if u really bricked the cmos
 
Jul 20, 2019
3
0
10
0
I know if i update my bios to a 3rd gen supported bios i loose support for the a8 cpus.

I dont see any of that noted for your board tho, likely since its b450.
That it’s what i think. After updating motherboard, i lost the support for the a8 so that now i am in a condition of a cpu too old and a cpu too new to be both accepted by motherboard. This is a weird situation.
 

ASK THE COMMUNITY

TRENDING THREADS