AMD Crimson Power Efficiency Toggle / Fiji Downclocking Issue

DreamcastERA

Honorable
May 12, 2014
14
0
10,510
0
I have had immense trouble with my R9 Fury Nano recently.

The card is great, yet I have noticed that it will constantly downclock itself from my overclock of 1020 all the way down to the 400-500 range. It does this while sitting at a steady 55 C (water cooled). I have seen the suggestions online that include:

- Adding a line to the registry to disable throttling.
- Disabling Power Efficiency in Crimson (Toggle is not there.)
- Updating to the latest bios.
- Removing overclock.
- Clockblock.
- Wiping and reinstalling drivers.
- Reverting to "working" drivers. (16.3 Crimson)
- Reverting to Catalyst 15.7.1 drivers.

From what I can see, disabling power efficiency toggle in Crimson appears to be the true solution, yet I do not have this option. From what I hear it is under Gaming -> Global Settings ; yet, as you can see, it is absent. This is making games like Overwatch unplayable at times.

System Specs:

- i7 3770
- R9 Nano
- 16 GB Crucial Ballistix

I would appreciate any help with the topic!

Thanks for the help in advance!

 

DreamcastERA

Honorable
May 12, 2014
14
0
10,510
0


I would absolutely be willing to! I have noticed that the nano does not take well to overclocking. Thanks for the quick response - do you know if ATIflash will work fine with the custom bios?
 

DreamcastERA

Honorable
May 12, 2014
14
0
10,510
0


Thanks for the attempt, I used the Air Bios and after one game of Overwatch, the GPU began down clocking to 300-400 once again :/

UPDATE:
I forgot about the H20 bios and I am giving those a shot now!

UPDATE:
They, sadly, had the same result. I ran heaven benchmark this time and after two minutes or so of max clock, it began to make erratic dips.
 
Don't know if this is related to the issue you're having, but your PSU (CX430) seems kinda under-powered for your build. I'm just looking at the build details you have in your profile though, maybe you've upgraded your PSU too.
 
First off, remove the overclock, if you used a third party utility for this, uninstall it and delete any saved profiles when requested, then reboot and retest.
If it's still the same, try setting the power limit to +30% in the global overdrive section and retest.
Also check the other system temperatures, preferably with something like HWInfo to give you a good idea how the entire setup is performing, also note the voltages it records, the CX PSUs' aren't the best ever made and seem to have an unusually high fan failure rate.
 

DreamcastERA

Honorable
May 12, 2014
14
0
10,510
0
First off, remove the overclock, if you used a third party utility for this, uninstall it and delete any saved profiles when requested, then reboot and retest.
If it's still the same, try setting the power limit to +30% in the global overdrive section and retest.
Also check the other system temperatures, preferably with something like HWInfo to give you a good idea how the entire setup is performing, also note the voltages it records, the CX PSUs' aren't the best ever made and seem to have an unusually high fan failure rate.
Just so everyone knows the vcore was overheating - thus why it appeared that it wasn't averheating. Because the core was cold. checking HWINFO and following his advice helped me find the issue. THANKS!
 

ASK THE COMMUNITY

TRENDING THREADS