AMD Driver display has stopped responding for HD6850

chris2b

Honorable
Jan 6, 2013
8
0
10,510
Ok this has been happening for months but it used to only happen here and there when I would be playing games for fairly long. Now It happens all the time and it makes my PC really slow. I've went into safemode uninstalled the drivers from device manager then used driver sweeper after before putting on a few drivers (tested 12.2, 12.10, 12.8, the beta and 11.something), using the same method however none worked.

I thought it could be dust keeping my card too hot but both my card and chip are at a stable temp and i've dusted and cleaned my graphics card and pc so that is covered.

I've gave the pc a fresh install and that also hasn't worked. When I use my pc in safe mode it works fine. I've no idea what to do. On event viewer it says "amdkmdap". I've looked on the troubleshoot website and i've got nothing from that. I could really appreciate some help here as this has been driving me mad.


Specs:
Graphics card: Power color HD6850
Chip: E5200 @2.5ghz (2 cpus) ~3.5ghz
Motherboard: Gigabyte P31-S3G
4 gig of ram
Windows 7 Enterprise 64bit

 

chris2b

Honorable
Jan 6, 2013
8
0
10,510
If it's worth anything, I have my pc partioned with windows XP and my pc works fine with XP and has no crashes, so I no its something to do with the drivers and windows 7.
 
try updating windows 7 and your bios

the problem might also be with you using 2 os...try it once only with win7

also remember drivers for windows xp & 7 are different

also check if you have any auto tuning utility running in win 7 and disable it if you have one
 

chris2b

Honorable
Jan 6, 2013
8
0
10,510
How would I update my bios? Windows 7 is fully updated however. And yes, i've used seperate drivers for seperate OS.

 

chris2b

Honorable
Jan 6, 2013
8
0
10,510
I updated it, I think? I ran the exe on windows xp and it just opened up that black box run/cmd kind of thing then it just closes down after, without much happening.

So I wasnt sure if it worked but when I try it on windows 7 it tells me its not compatible with windows 64 bit but It doesnt give you a choice on the website.

When I did go on windows 7, it still had the common crash though
 

chris2b

Honorable
Jan 6, 2013
8
0
10,510
Well I upgraded my PC as it needed an upgrade changing the motherboard, harddrive and ram but it still occured. Wondering it may be my power supply and when I put it in my friends pc it went amd drivers not displayed then blue screen before resetting.

I've emailed power color about getting it repaired or replaced but will this work considering the card is about 14/15 months old?