AMD Dual-Core Optimizer not being installed???

TGYoung

Distinguished
Jul 23, 2007
7
0
18,510
0
Hi all:

Recently acquired an HP box with an AMD Athlon 64 X2 4800+ running Windows Vista.

One of the first games I installed was Quake 3 and it ran poorly, with a semi-periodic brief pause in the game every couple of seconds or so.

Looking around the Internet I came upon the "AMD Dual-Core Optimizer" at AMD's site. The write-up said "The AMD Dual-Core Optimizer can help improve some PC gaming video performance by compensating for those applications that bypass the Windows API for timing by directly using the RDTSC (Read Time Stamp Counter) instruction."

Although I wasn't sure if that was the issue with Quake 3 I figured installing the Optimizer couldn't hurt, so I downloaded and intalled it. Only thing is, it doesn't seem like it's really installed on my machine. The "AMD Dual-Core Optimizer" shows up in the startup list and is available to be uninstalled via Control Panel\Programs and Features. But, when I run Device Manager and look at the drivers for the processors I see:

Driver Provider: Microsoft
Driver Date: 6/21/2006
Driver Version: 6.0.6000.16386
Digital Signer: Microsoft Windows

where I'd expect to see a driver provided by AMD. And Q3 still runs like crap!

How can I tell if the AMD driver is installed and running? And how do I get Q3 to perform properly on this machine!

TIA.

Tom Young
 

gudodayn

Distinguished
Feb 15, 2006
236
0
18,680
0
Before we get to the dualie optimizer driver..............
What are your specs with this HP box?
Have you tried other games and getting the same lag problem?
Does the lag problem only happen in gaming or does it happen in media player playback or system response lags as well?
 

YO_KID37

Distinguished
Jan 15, 2006
1,277
0
19,280
0
What Graphic Card or Graphic Processor are you running on? and what kind of setting are you running? And also is that a Legal CD run Quake or a "Illegal" Run-on-Hard Disc version?
 

Hawkeye22

Champion
Moderator
Feb 10, 2006
11,445
0
51,160
1,070
I don't know about Vista, but under XP you will see something similar to this in the event log if the optimizer is installed.

RegisterTscDrift()
Node[ 0 ] Core[ 1 ] Cpu[ 1 ] Affinity[ 0x2 ]
Thread registered succesfully: SamplingRate(ms)[ 1000 ]
 

skittle

Splendid
Dec 27, 2006
4,042
0
24,660
481
ah ive actually been playing Jedi Academy for.... around 5 years now (im friggen amazing at that game)


Anyway JKA also uses the quake 3 engine and does run poorly on dual core AMDs!!! I have an x2 3800+ and a 7800gt... runs like **** if i dont fix it.

solution??!?!?! dual core optimizer doesnt workfor quake 3, i tried it...

THIS IS THE SOLUTION FOR YOU!!! :

Set the affinity for quake3 to just one core and you will see your frame rates roughly double. haha seriously try it in game, its awesome seeing your framerate jump up to like 200+ when it was running at around 40.
You can do this manually via task manager, or you can find a program that does it for you everytime you start quake.



soooo glad i could help :)
 

TGYoung

Distinguished
Jul 23, 2007
7
0
18,510
0



It's not blockbusters - Athlon 64 X2 4800+ @2.5 GHz, 2 x 1GB PC4200 RAM, integrated vVidia GeForce 6150SE video - but it's more robust then my old box which ran smoothly at 125FPS. I've not noticed the problem otherwise, and haven't installed any more games until I get this figured out.

Thanks.
 

TGYoung

Distinguished
Jul 23, 2007
7
0
18,510
0


It's an integrated nVidia GeForce 6150SE and the game was installed from a legal CD then undated to v1.32.
 

skittle

Splendid
Dec 27, 2006
4,042
0
24,660
481
READ MY REPLY

SET QUAKE AFFINNITY TO ONE CORE, YOUR FRAME RATES GO WAY UP
 

TGYoung

Distinguished
Jul 23, 2007
7
0
18,510
0


Well, I'm not seeing that, though I've never really messed around with the event log. I'm seeing quite a few warnings and errors though, that I may have to follow up on.
 

TGYoung

Distinguished
Jul 23, 2007
7
0
18,510
0

 

TGYoung

Distinguished
Jul 23, 2007
7
0
18,510
0


I should have thought to ask: what does Device Manager show as the driver for the CPU?

Thanks.
 

Hawkeye22

Champion
Moderator
Feb 10, 2006
11,445
0
51,160
1,070
Device manager will show the CPU driver as Microsoft. The task manager may show the optimizer running. I can't remember off hand because I uninstalled the optimizer. My computer ran better without it. It definately registered in the event log upon every reboot.

Again, this was all under XP Pro. Vista may vary.
 

TGYoung

Distinguished
Jul 23, 2007
7
0
18,510
0



OK, I finally found it in the event log, so that question's answered. In a way, it's a little disappointing that the Optimizer *is* running as now I've got to keep working out why Q3 won't run on this box. Thanks for pointing me in the right direction.

 

Similar threads