AMD FX-8350 + GTX 970 constant fps drops

Danko10

Reputable
Nov 28, 2015
2
0
4,510
0
Hello!
I just finished building my custom PC and the very first day(today) I started playing games like Fallout 4,The Witcher 3 and Heroes of the Storm I noticed sudden and very frequent fps drops from 70-80 to 18 and then getting back to 70-80. The CPU is using all processors and I am running Windows 7. I changed the cooler on the AMD CPU since it was heating too much when not doing anything,60°C, changed it with a Zalman cooler(can't remember the exact name) which was going to hold better.
I would appreciate any help that I can get with resolving this problem since this is my first gaming PC and I don't want to have problems that will persist since day 1.

My Rig:
AMD FX-8350
Asus Geforce GTX 970 Turbo
ASROCK 970 PRO3 R2.0, AM3+, SB950, 4xDDR3, 6xSATA 3
Kingston HyperX FURY 8GB Kit (2x4GB) 1866MHz DDR3 CL10 DIMM
Seagate 1TB Solid State Hybrid Drive SATA 6Gbps 64MB
Xilence 700W 80 Plus Bronze

(I know,the power supply may not be good,but I will change it soon)
 

knobgoblin

Reputable
Aug 13, 2015
16
0
4,520
4
What's your temperature under load with the new CPU cooler? AMD CPUs (especially the FX series) can really run hot and slow things down. Fallout 4 and Witcher 3 both use Nvidia Gameworks as well, so you might want to try turning TXAA, Hairworks, Godrays, Bokeh, etc., off or set them to low. Fallout 4 is also a very "meh" PC port, which isn't optimized as well as most people would want it, so big FPS drops can be expected when running around Diamond City and the Institute.

Quick Edit: Your PSU isn't that bad, it should be able to handle what you're throwing at it.
 

synphul

Polypheme
Moderator
Even if the cpu temps are brought down by the aftermarket cooler there could be some heat issues with the vrm. That motherboard is only a 4+1 power phase board with no heatsinks on the vrm which isn't helping matters. Going from a top down style cooler to a tower style cooler blowing air either up to the top of the case or straight to the rear means the vrm are no longer being cooled by the air being blown down as with the stock cooler.

Fallout4 might be a bit buggy yet being a new release. Amd's fx cpu's aren't as strong as intel's either so fps differences can be significant. The fx 9590 and 8370e (around the type of performance from an 8350) show min fps dropping into the low 30's or under and averaging in the low 50's at 1080p ultra. I5's and i7's on the other hand only dip to the high 40's/low 50's and average well over the capped 60fps.

http://www.gamersnexus.net/game-bench/2182-fallout-4-cpu-benchmark-huge-performance-difference

Witcher 3 shouldn't be as bad but again fx cpu's are a bit more prone to erratic fps and periods of fps dropping. Again part of the issue may be the vrm causing the cpu to throttle back some.
 

michaelnrn

Honorable
Apr 17, 2013
64
0
10,640
1
Ift possible, since your parts are new, maybe you can exchange / swap that mobo for something a little more prepared for that type of power load. Most 990FX boards will have an 8+2 power phase. I'd try that, if it's easy for you to do. You can also reseat everything, put on the appropriate amount of thermal paste on your CPU.

Unfortunately, the CPU you picked is power hungry and runs hot. I wouldn't be surprised if there are issues revolving around that just based on the board you currently have. Just as a side note, overclocking is a great feature with that proc, and is NOT an option with your mobo.

I don't want to recommend switching to AMD's competitor, only because it likely wouldn't be well received here, but if that interests you, and exchanging parts is possible, I'd be happy to recommend a motherboard / CPU combo, you can PM me if you'd like.
 

Danko10

Reputable
Nov 28, 2015
2
0
4,510
0


The GPU temperature in-game hits a maximum of 80°C and I didn't look at the CPU temp. in-game but in bios it is at 50 °C when doing nothing. But I noticed that in-game the CPU uses the cores 1-3-5 around 50% (core 1 at 70%) and the other 5 cores at around max 28% (some 0-10%). Is it normal?
And can the fps drops be from the SSHD? since it is a laptop SSHD so it is slower. Will it help if i get a hard drive of 500MB?

 

michaelnrn

Honorable
Apr 17, 2013
64
0
10,640
1


I don't think your hard drive is an issue. I have an SSHD and it doesn't give me any problems. Once your game is loaded the hard drive shouldn't drag you down really. If your CPU is showing 50 C in BIOS, that is concerning. I don't know the threshold on those chips, but if you're idling at that then you should definitely look in to reseating your CPU and make sure you have used the right amount of thermal paste.
 

Ravi_Singh1900

Reputable
Oct 26, 2015
101
0
4,710
10
My rig has a fx 8320 at 4.4 ghz with a gtx 970 and I have fps throttling issues but they are flip second throttle. Crysis 3 (v.high) 70-42 fps, Witcher 3 (42-63 fps), fallout 4 maxed out: (35- 80), although frame rate dip they dont go below playable point ever like in your case and they dip for a flip second.

Note: Fallout 4 has hdd streaming issues, u will need a ssd to completly remove any shutter when entering new area.

1. Reduce overclocking if any, your cpu is heating up and AMD cpu seem to perform bad when they are heated up above 60 Deg C.

2. Disable C6 state power saving and disable turbo core it will reduce throttling to some extent, but cant get rid of that completely on AMD processor. Flip second throttling would still be there but normally you fps will stay at higher side.

3. Use these hot fixes for windows "441065_intl_x64_zip.exe" & "441280_intl_x64_zip.exe". Search these hotfix on google and install them. These are not provided in windows update, you will have enter you email id in microsoft website and link for download would be sent to you. These hotfixes did improved my minimum frame per second.

Hope this helps!
 

Rnato35

Reputable
Jan 2, 2016
11
0
4,510
0
I had a similar problem, had to disable some options in the BIOS that would mistakenly throotle the CPU when it wasn't necessary. I can't remember all of them but some were:
Cool n' Quiet, Turbo core, Core C6 State(I think), and any other power saving or silent features.
Good luck!
 

Cryio

Distinguished
Oct 6, 2010
881
0
19,160
52
1) Change to Windows 8.1 or Windows 10. It works better and faster than Windows 7. 8.1 at least is vastly more reliable than Windows 7. And you won't be able to use the better quality drivers.
2) CHECK for core parking EVERY TIME you start a game. EVERY TIME. in CPUs with more than 4 threads, the Windows OS generally puts the remaining cores to sleep or in power saving mode. Therefore, your FX 8350 is usually only properly using just 4 cores out of 8.

Mess with the core affinity in Task Manager and every game will start using all your cores, you'll have better framerates and you'll have fewer drops.
 

Candan

Honorable
Jul 27, 2014
233
1
10,715
12


Danko, having had the same FX8350, same GPU and the same mobo in the past, I can tell you that 100% without doubt, it's throttling due to overheating on your MOSFETS (this board has minimal heat-sinks around the CPU.) This board uses a 4-1 power phase. You want at least a 6-1 (Asus M5A99FX Pro R2.0 is a good AM3+ board with a decent chipset that will stop your issue)

https://ca.pcpartpicker.com/part/asus-motherboard-m5a99fxpror20

Of course, good cooling by air is better for the board you have in case you're using liquid coolers at the moment. Liquid coolers with this board will make the situation worse. You could try going into your bios and deactivating 2 of your 8 CPU cores. Not for a permanent fix, but it should then create less heat and positively identify your issue.

 

Bacamakaca

Commendable
Feb 25, 2016
3
0
1,510
0
Hi guys, i'm new to this forum.
BUT I KNOW THE SOLUTION!!

i had the same problem with my fx 8120, and i played for 2 years with fps drops. The method how to fix it is very easy:
1. go to power options on your pc
2. go to edit plan settings
3. click on change advanced power settings (i think its written like that)
4. scroll down and go to processor power management
5. change minimum processor state to 99%, and change maximun processor state to 99%.
6. save it

This fix is permanently, so you don't need to do it again. i found this solution when i was on my 10 year old pc, and went to this settings, and i saw this processor power management by accident. i looked on my own pc and it was on 100%, and that is WRONG!

Sorry for my english, i hope i helped you.
 

vitoz007

Reputable
Feb 6, 2016
28
0
4,560
5


Thanks man! I just tried taht and got better temp and more FPS while playing battlefield! Do u have more info about this issue? looks like there something..
 

Bacamakaca

Commendable
Feb 25, 2016
3
0
1,510
0
I do have some info, it id actually the VRM on your motherboard that ovethrating, first the fps drops came i 5:38min, and after playing 2 hours it was 2:24min. i really measured it with a stopwatch. The VRM is overheating, and is throttling the CPU. a better motherboard would fix this, but this solution works for now. Im only scarred that the VRM can overheat now. Maybe someone can figure it out if it can break.

Again sorry for my english, i hope i helped yoi
 

Bacamakaca

Commendable
Feb 25, 2016
3
0
1,510
0
UPDATE:

I figured out you can prevent the VRM of overheating when you change your MAXIMUM processor state to around 70% ~ 80%. it works well when it's 99%, but with 75% my CPU's temperature is way lower and FPS drops are shorter.
 

ASK THE COMMUNITY

TRENDING THREADS