Question amd help

marcoos

Distinguished
Jan 30, 2012
34
0
18,530
Best answers
0
ok this is my problem ive got a AMD ADX645WFGMBOX Athlon II X4 645 Quad-Core Processor (3.10 GHz, 2MB Cache, Socket AM3, 95W put it in about 2 weeks ago and it was working fine for about a week then it over heated and shut down so i opened the machine and noticed the heat sink became loose reason was the the clip on the retainer bracket had snapped so i got a nother one and fitted it put every thing back together every thing is secure and now its still over heating could the processor of blown ?it shuts down as soon as it goes in to windows anybody got any ideas many thanks
 

PC Tailor

Estimable
Jun 29, 2017
2,326
235
3,740
Best answers
392
What cooler are you using?
Where are you monitoring the temperatures and what are temperatures getting up to?

Are you sure it's properly connected with an appropriate amount of thermal paste?
This still sounds initially as though the cooler is not seated correctly.
 

marcoos

Distinguished
Jan 30, 2012
34
0
18,530
Best answers
0
just a normal heat sink its an old machine its the one where the clasp goes throgh the heat sink and it wont stay on long enough to get temps and from what i can see its seated firmly?
 

marcoos

Distinguished
Jan 30, 2012
34
0
18,530
Best answers
0
ive replaced that part put everything back to normal and now when you switch on the temp rises and shuts down ive got thermal paste on there been into bios and under pc health under cpt controll it rises to 80 then shuts down the system temp is at 25 any ideas?
 

ASK THE COMMUNITY

TRENDING THREADS