Question AMD Radeon HD8490, DirectX11, "Feature Level 10.0 is required"

mistersilent

Reputable
Jan 8, 2017
7
0
4,510
0
I have an HP Compaq Elite 8300 Desktop running Windows 10 and recently purchased an AMD graphics card so I can play some games, like Fortnite, while I'm home instead of the default Intel integrated graphics. However, upon installation of AMD's drivers, an error message occurs when attempting to run Fortnite saying "DX11 Feature Level 10.0 is required". I have checked device manager and feature level 10.0 is installed as well as other versions (11, 12, etc.). I tried re-downloading DX11 from Microsoft, but to no avail. When I attempt to update the GPU drivers through Device Manager, it installs Microsoft's Basic Drivers (which does not solve the issue and actually messes up the aspect ratio on my monitor). Any help in solving this would be much appreciated. Thanks!
 

NightHawkRMX

Illustrious

NightHawkRMX

Illustrious
What drivers have you installed? I can't find any on AMD website, not for Windows 10: https://www.amd.com/en/support/graphics/amd-radeon-hd/amd-radeon-hd-8000-series-oem/amd-radeon-hd-8490

Try what NighthawkRMx wrote.
I couldnt find any either, but the card was only 1-2 years old when Windows 10 came out, so it has to have Windows 10 drivers somewhere. My hope is that the auto driver installer tool from AMD will find the correct ones.

I doubt the latest drivers work on this card, but i guess its possible.
 
Reactions: RodroX
With the age of the card, I think you're not going to find drivers that adequately support what you need to run it.

And to be honest, this isn't much of an upgrade if even an upgrade. A lot of igpus are hitting higher texture rates. I'd step up to at least and r-series card.
 
Reactions: RodroX

ASK THE COMMUNITY

TRENDING THREADS