Question AMD Radeon Pro W5700 not detected in Bios

Feb 29, 2020
1
0
10
0
I have a WORKING Dell Precision T3600 workstation, windows7, Nvidia Quadro P2000 video card. 635w PSU (1300w PSU has been ordered and is on the way)
This computer does not have integrated graphics

I purchased an AMD Radeon Pro W5700 video card to upgrade the system.

Before upgrading the hardware, I updated the MOBO Bios and downloaded the AMD drivers (cant install yet because AMD hardware not installed)
Anyways, I removed the working Nvidia P2000 and installed the AMD W5700. I plugged in the power cables and turned the system on, the fan on the W5700 came on, but no video output, cant get into bios, nothing. I tried all 5 displayports and tried different cables, monitors, etc. To troubleshoot, I removed the card and installed it into a second pcie16 slot, still nothing.

I reinstalled my Nvidia P2000 card alongside the AMD W5700 and am able to get video output on the p2000. Looking at the BIOS, the nvidia is detected, but the slot that the W5700 is sitting in shows as "empty". I swapped the PCIe positions of the video cards, again the P2000 works and the W5700 does not. The Bios still shows the slot where the W5700 is as empty.

The W5700 card has 8-pin and 6-pin power connectors. My PSU has two 6-pin connectors. Will this card not power up unless it has the proper 8 pin power connected? The 6-pin PSU connector does fit into the 8-pin connector on the card (its the same as the 6+2 connector on most aftermarket PSUs, just minus the 2). I asked this question to AMD tech support, but they have been unresponsive. I also ordered the cable adapter to convert a 6-pin into an 8-pin (just in case)

FYI, Never purchase a Dell workstation, the proprietary parts like PSU's make everything unnecessarily difficult.

Any help would be appreciated, Thank you.
 
It sounds like your specific problem is the lack of two pins on your power connector.

Keep in mind that Dell computers are often BIOS locked to specific equipment/vendors, so even when you do get a proper adapter for your GPU it may still not work.
 

ASK THE COMMUNITY

TRENDING THREADS