AMD Radeon r9 390 Freezing/Black screen issue

Jun 30, 2018
2
0
10
0
Specs:

MOBO: Asrock extreme3 r2.0
GPU: MSI R9 390
RAM: 4GB Patriot (2x2) 8GB Crucial (4x4)
CPU: AMD FX-6300
PSU: 750W THERMALTAKE
STORAGE: SSD 120GB, 750TB WD
WINDOWS 10 64BIT

Everytime I boot into windows, the computer freezes or goes into a black screen. Afterwards I would have to reboot it. This only happens once logged into windows, but when I am in safe mode OR uninstall the driver it doesn't freeze. I know it's something with the drivers. I've also noticed that the GPU fan stops spinning once it logs into windows. Upon boot, shutting down and safe mode it spins. I read from peoples posts that the GPU fan is supposed to be off until it's needed? Here's what I've done so far, please do not recommend something I've already done:
-Reinstall Windows
-Try another graphics card (still happens)
-Boot into safe mode and run the DDU to remove old drivers/registry keys
-Let windows reinstall the driver/ Let the auto-detect from AMDs website grab the driver/ Manually find and install the driver.
-Reseat the RAM
-New PSU

Please helppppp :(
 
about the fan you need to check if your card support "0db feature" or not. it is feature that will only let the fan start spinning when the temperature reach to certain level (usually 60c and above) to minimize the noise generated by the GPU. about the black screen issue that is something common with AMD card before polaris/vega generation. did you use the latest driver from AMD?
 
Jun 30, 2018
2
0
10
0


Hey thanks for the response. I’ve realized that it does turn on when it reaches a certain temperature. I’ve definitely tried using the latest driver, and it happens more often with the latest. If I try an older one after running the DDU it does last maybe 5 minutes Longer before the black screen.
 

Similar threads


ASK THE COMMUNITY