Question AMD Radeon RX 590 --- No signal after BIOS Splash Screen ?

Apr 22, 2021
1
0
10
0
Hello everyone,

I' ve been trying to solve this super weird issue on my own for many days now to no avail....so much that I decided to create a user here and give it a shot.

My system was working flawlessly until next time i powered it up, boom, no signal on my samsung 4k tv.

I've read similar posts here but most of them are regarding NVIDIAs. af

So yeah the issue is that video signal is lost as soon as windows starts to load...sometimes i get a micro second of login screen, but 99% of fthe times I cant even see the windows splash logo nor anything like that, it just goes blank after bios splash.

It works in safe mode and it works in normal mode after I uninstall everything in safe mode and get the windows basic adapters but as soon as Im isntalling the adrenalin drivers for the card it blanks again.

Ive ddu the hell out of it, tried different driver versions, the newest ones from amd that let you install the drivers alone without radeon software, etc. Nothing.

System is quite new its an x570 plus wifi mobo with a ryzen 5 3600 and 750w PSU.

I took the tower to the shop to try it out with a different monitor and IT WORKED! I could install the latest radeon software and all. I then lowered the display res at the shop and came quickly home to try it out and IT WORKED...that was until the next boot, then the same thing started to happen all over again. How can one explain that behaviour?

Im at a loss here guys....any assistance or light to guide me through this darkness would be so much appreciated.

Thanks in advance!
 

ASK THE COMMUNITY

TRENDING THREADS