Question AMD Radeon software stuck while installing

Dec 7, 2021
4
0
10
0
while updating to the newest drivers my system got stuck at about 70% for a few hours, and it didn't seem like it was moving, and when I attempted to to close the installer it just crashed which left me with no drivers and no Radeon software because the installer uninstalled them to install the new software. I then downloaded new drivers from AMDs site and attempted to install new drivers, only to find that when the AMD driver installer launched it was stuck at "detecting your pc's hardware for driver and hardware compatibility" and stayed there for another few hours. Yet again when I tried to close the installer it wouldn't so I decided to force close it. after this I restarted my pc and tried again, when the same issue arose I turned to the Internet, and found that some slightly similar issues, were solved by either removing the drivers via AMD cleanup tool or by just deleting the AMD folder. After doing both (on different attempts) with no success I just didn't no where to go. If anyone knows anything that can try to fix this it would be so helpful.

my pc specs are:
  • AMD Ryzen 5 3600
  • Asus Prime B550M-A WIFI
  • Corsair Vengeance 32GB 3600mz cl18
  • PowerColor Red Dragon AMD 5700xt
  • SP M.2 PCIe Gen 3 SSD 256gb NVME/boot drive
  • Seagate Barracuda 2TB HDD
  • Seasonic 650w PSU 80+bronze
  • NZXT h510i case, with 4 case fans
 
run DDU from Windows' Safe Mode and remove all graphics related data.
then try again.

if this still fails;
revert to any available Restore Point from before this happened.
then try again.

when re-downloading maybe try saving the files to another disk.
 

ASK THE COMMUNITY