Question AMD RX580 Monitor turning black problem.

Jul 27, 2019
6
0
10
0
So, I just bought a new GPU and it's a AMD Radeon RX580, I Reinstalled my Windows 10 and then Installed the GPU, no problems here.

I Turned my PC on, everything was running fine, but when I started to run a Game the Monitor goes black, I hear a very weird sound in my headphones and the PC keeps running.
In the past I had an GTX 960 from MSI and It worked perfectly, and If you think that the Monitor is the problem, well, it's not, because It's running fine on my other PC, and no problems there.

The PC specs:

CPU: i5 6402 CPU 2,4Ghz
GPU: AMD Radeon RX580
RAM: 8GB Ram DDR4 (One Stick)

Things I tried:

  1. Trying to see if everything is ok in the Case with the screws, cables, etc.
  2. Updating Windows
  3. Changing the Monitor
  4. Moving the RAM in another Slot
  5. Playing with the AMD Software
  6. Optimizing the PC
And If this helps: When I had the GTX 960 and Tried to install a 4GB Ram DDR4 Stick, The PC Would do the same problem with the Monitor, It would keep running with the monitor closes.

If somebody can help me, that would be so great! Thanks you in advice!
 
Nov 18, 2019
99
7
45
3
There is a forum a few months back that talk about this issue maybe even some where on this forum on how to do the fix.

It happens the first time installing the RX 580 on Windows 10. Don't worry it's not broken the already installed HD Audio driver is not playing nice. Do you also have echo in your sound as well. If not you will. Ask me we have 3 RX 580's one for my son one for me " DAD " and one the wife has never been told that also came on the order and out of sight before she looked in the box.......so we have only two honey cough cough lol.

Another weird install glitch, is not always but sometimes when loading new drivers your desk top will have a green color and don't freak it's okay just reboot all will be good.

So how to fix just dump your newly installed fresh driver. " ya I Know" reboot do a fresh install of the same driver , reboot and problem works it's self out. But first thing I would do is gently reseat Video Card just so your not chasing ghosts just in case. And like asked above Power Supply ?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS