AMD ryzen 3 2200g, vega graphics not showing up under adapters in device manager.

leroy_125

Commendable
Jan 11, 2017
2
0
1,510
0
I built a new system about a month ago. specs as follows.

CPU: AMD Ryzen 3 2200g
MOBO: gigabyte ga-ab350m-gaming 3
GPU: evga geforce gtx 1060
RAM: Ballistix Sport LT 8GB Single DDR4 2666
SSD: PNY CS1311 240GB 2.5” SATA III Internal Solid State Drive (has windows 10 pro on it)
PSU: EVGA 500 BQ, 80+ BRONZE 500W.
OS: windows 10 pro x64 version 1709

When I first put it all together, both the AMD vega8 graphics and my geforce were showing under display adapters. However during the first week, i got a lot of blue screens and freezes while gaming. So I set about troubleshooting. One of the first things I did was disable and uninstall the drivers for the vega graphics, thinking the BSODs might be related to a graphics driver conflict, I believe the vega graphics were showing a yellow exclamation mark at the time although I am not a 100% sure.

Since then I have found the faulty driver and fixed the BSODs (they had nothing to do with the graphic drivers).

However now when I try to reenable the vega graphics again so I can run a proper dual screen setup (I don't need it for games, mostly for work / graphic design), it won't show up. When I scan for hardware changes in device manager it won't show up. When I download the APU drivers from AMD to install for the vega graphics, it says "no supported hardware found".
I just can't seem to find a way for windows to recognize the vega integrated graphics on the CPU.
All drivers have been updated to latest version, BIOS has been flashed to latest version.
I've also checked the BIOS peripheral options to see if the option to enable integrated graphics is there, but it is not, due to the MOBO not having onboard graphics and relying on the cpu to supply them I suppose.

Has anyone else run into this issue and found a way to re enable them, or am I going to potentially have to suck it up, go with a clean install of windows to start fresh?
 
Suggest you reset your BIOS and 'enable' the gfx in BIOS. You may need to pull the gfx card to get it to take. Try it with gfx card first though.

Then I suggest you boot to safe mode, and check out the installation state of your hardware / drivers, and monitor setups (or as much as you can within safemode, given that it disables drivers).
 
Suggest you reset your BIOS and 'enable' the gfx in BIOS. You may need to pull the gfx card to get it to take. Try it with gfx card first though.

Then I suggest you boot to safe mode, and check out the installation state of your hardware / drivers, and monitor setups (or as much as you can within safemode, given that it disables drivers).
 

ASK THE COMMUNITY