Question AMD Ryzen 7 5800x permanently at 100% (and over)

Jan 19, 2022
2
0
10
0
I am at my wit’s end.

Had no issues with PC after installing new CPU over a month ago, never overclocked. Two days ago, I was playing VR (Oculus Quest 2 via AirLink, not that I think that matters) and everything was completely normal. Turned off PC like usual when I was done.

After work the next day, turned on my PC to play VR again and noticed immediately that as soon as the PC had to load anything visually, the game tanked and dropped to 3-5 FPS and became very unstable. Figured it was a router bandwidth issue so switched to a physical cable to Link but the exact same issue was present.

Sat down to try more conventional gaming and while things mostly seemed to run fine (better than the VR), the games were very prone to stuttering and were unstable as well. For example, trying to change the game resolution from 1080p to 1440p would cause the game to freeze for 15+ seconds, and half the time this would then cause the game to complete crash to desktop.

I also noticed that if I had a video/movie playing on VLC or the Videos application, opening a file or really clicking on anything would cause several seconds of stutter in the video, which I had never experienced before. Naturally, I figured something may be up with my CPU. Sure enough, I opened task manager and it was sitting at 100% use. This does not seem tied to any specific application or process, and TM will read that whatever I have running in the foreground is using 90% or more of the CPU. If I close everything and have no applications running, the CPU will read that it’s being used by various Windows processes.

I tried numerous first and third party hardware monitoring apps to see what was happening and they all agreed that my clock speed was constantly sitting between 3800mhz and 4700mhz (usually closer to 4700) despite it supposedly having a non-OC max speed of 3800. I then went through every setting I could think of to see if this was being enabled somehow. I checked the AMD proprietary software, which read the abnormally high speed and usage but all my OC and manual settings were normal. My UEFI settings all seemed normal and unchanged, all reading non-OC. I updated my UEFI anyway, to no avail.

I reinstalled drivers for every component of my PC, to no avail. I did a full reinstall of Windows, to no avail. I did see that for some reason the minimum processor state for the High Performance Mode had become set to 100, but changing this had no effect on the issue.

I DID notice, curiously, that changing the Windows Power Mode settings seemed to have some effect. EVERY single mode except ‘Balanced’ leaves me with my now-usual issue of CPU usage, with no difference between the modes. ‘Balanced’ causes the Task Manager readings to go back to normal, but the other hardware monitoring tools still say that it’s now sitting at 3800mhz constantly, while occasionally spiking back to 4700mhz if I open a new application or something.

Build:
AMD Ryzen 7 5800x
EVGA Nvidia 3080ti FTW3 Ultra
MSI B450 Gaming Pro Carbon AC
32gb Corsair Vengeance RGB Pro (2x16gb) @3466
EVGA SuperNOVA 850w 80Plus Gold

Mod Edit for content
 
Last edited by a moderator:

keith12

Illustrious
Hey there,

Do you have the Ryzen balanced plan in your options? This is the one you should be choosing. If it's not listed, then you need to go to mobo manufacturers website, and download the chipset driver which will contain the Ryzen power plan.

Let us know how that goes.
 
Jan 19, 2022
2
0
10
0
Hey there,

Do you have the Ryzen balanced plan in your options? This is the one you should be choosing. If it's not listed, then you need to go to mobo manufacturers website, and download the chipset driver which will contain the Ryzen power plan.

Let us know how that goes.
Sorry, I should have mentioned in my original post - I already made sure that my mobo (and other) drivers were installed and/or up to date. I have the Ryzen power plans and only the Windows Balanced option makes the task manager read a normal CPU usage, although CPU-Z etc all still read a constant 3800mhz. I should also mention that I tried booting into safe mode and all that changed is that the CPU stayed constant at 3800mhz on any power plan, no spikes above it. It's as if my CPU has been overclocked and set to run at 100% despite every relevant setting saying otherwise.
 

ASK THE COMMUNITY