Question AMD Ryzen 9 5900 90 Degrees Idle

Jan 7, 2021
5
0
10
0
Hey.

i built my pc today. I neatly connected all cables. when i started my pc i was shocked by the temperatures of my processor. It reaches 90 degrees Celsius when idle. The AIO makes noise from the liquid that goes through the cables and the RGB works. only in the bios is AIO pump speed N / A. what does this mean, is this the reason my temperature is so high? Did I put too much thermal paste on it or is the cooler not sitting properly on the CPU.
Please help me!
MOBO: Asus Rog Strix X570 E Gaming
CPU: AMD RYZEN 9 5900x
AIO: Cooler Master Masterliquid M360LR
 

RealBeast

Titan
Moderator
If the fluid is circulating and the radiator fans are running, most likely the cooling block is not seated well. Too much paste would give you a small increase but nothing that extreme.

edit: did you attach the AIO pump to the motherboard header for it?
 
Jan 7, 2021
5
0
10
0
If the fluid is circulating and the radiator fans are running, most likely the cooling block is not seated well. Too much paste would give you a small increase but nothing that extreme.

edit: did you attach the AIO pump to the motherboard header for it?
Yeah everything is working fine and the AIO cable is attached to AIO_PUMP header. And about the block I also think that it is not good in place, because had some trouble securing it. and it already seemed a little skewed on the CPU.
 
Jan 7, 2021
5
0
10
0
Well I think I know how to fix it, the thermal paste probably dried out and the AIO can’t cool because of that. So what I’m gonna do now is reapply the AIO block and the thermal paste. so hopefully it’s gonna work afterwards. :)
 
Jan 7, 2021
5
0
10
0
You built the PC today. The thermal paste cannot be dry.
well look, I couldn't easily get the cooler on the CPU everything was smeared because it didn't work. then I got mildly irritated and stopped for an hour. then I tried again and then it worked but now I have a CPU that indicates 90 degrees ..
 

ASK THE COMMUNITY

TRENDING THREADS