Question AMD Software won't open

Vid Nikolic

Nov 2, 2012
So, this is my problem.
Everything was fine about a year or something ago.
I think it started happening around summer 2021.
I just can't open Radeon software on my PC.
I tried everything, reinstalling the Windows 10, switching to Win 11 even though my PC is not supported. Blocking driver update on Windows and then installing. Deleting the drivers using various programs, including the AMD one.
I must have reinstalled Windows 20 times by now, I just can't get it to work.
Drivers do install, but when I try opening the Catalyst, icon disappears and another one appears, like driver has crashed and restarted. After a while if I don't hover my mouse over tray icons for them to disappear, there can be like 5-6 Radeon icons.
Tried deleting the CN folder. Tested RAM using Memtest and Windows Ram test.
Any help is appreciated.
Mind you, this only happens on this one PC, I can get the drivers to work on others.
Also, when I open the CN folder, there is a log that has this lines:
2022-09-27::14:32:14::362 GetEligibleDriverDetailsSize :37 Get eligible drivers Size started---------------------
2022-09-27::14:32:14::362 ADDL::getURLVersionJSON :1335 DEBUG No Server Ip found
2022-09-27::14:32:14::362 ADDL::getURLVersionJSON :1343 DEBUG No Servertype found
2022-09-27::14:32:14::362 ADDL::isVersionCompatible :621 DEBUG Downloading a file from server: . Download destination: C:\Users\vid-d\AppData\Local//AMD_Common//addl_details.json
2022-09-27::14:32:14::362 ADDL::eek:pen_json :903 failed to open json fileC:\Users\vid-d\AppData\Local//AMD_Common//addl_details.json
2022-09-27::14:32:14::362 ADDL::isVersionCompatible :735 failed to parse downloaded version.json file
2022-09-27::14:32:14::362 ADDL::validateInput :209 DEBUG Failed to download Version.json from server
2022-09-27::14:32:14::362 GetEligibleDriverDetailsSize :51 DEBUG validation failed

My specs on this PC are a bit older though, but that should not be the issue.

Processor i5 3570k - tested on stock speeds
Motherboard Asus P8Z77 Pro - latest bios
Ram - 1866mhz Patriot Extreme Masters
Using SSD.
GPU - Tested Radeon RX 580, RX 590, and older 7870XT

Vid Nikolic

Nov 2, 2012
Thank you for the reply! I was not sure someone would try to help haha. :)

Well, here is the thing. I kind of understand it has something to do with signal.
What I did try is turning off the firewall completely, nothing changed.

I also have 3 other PCs that are newer, and all of the mentioned GPUs work on them, drivers all good.
Using the same router, same network, to connect to the internet.

So it must be something specific to this PC (this motherboard or something)

I am using Chrome for the internet, Firefox also works, Opera, Brave, Edge, all work as normal. I work from home and my work requires couple of browsers with lots of tabs open, so I would notice if something did not work or load.

But this is an internal AMD log, can you please explain how is that related to the browser I use? Does AMD Catalyst use my browser to show splash screen?

Because from what I understand, I think it has a problem connecting that initial page that drivers show, one with advertisements and such, but maybe I'm wrong.