• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Android Update Has Broken All the Video Apps

Jul 9, 2020
1
0
10
0
I have a 2015 Sony W800C Android TV running Android 8 and i have never had an issue with it until it updated itself 2 weeks ago from Android 7 to 8.

Straight after the update, i noticed it wasn't playing my media.

I have a simple setup, and it includes a 1TB Hard Drive containing all my movies on there, and i simply plug the HD into the back of the TV into one of the USB ports, and use a video app, mainly Kodi as of recent, but previously i used NOVA Video to play my files.

The first 'issue' i notice, and tbh it's not really an issue, but my HD was named as 'Multimedia', but since the update it shows up on the TV as simply 'M'. Not an issue, but just a weird thing i have noticed since the TV updated itself and could be somehow part of the reason for the following issues?

So now to the real issues i'm having. I'll start with Kodi. Kodi used to check for updates when the app was opened on my TV, it used to take no more than about 30 seconds to quickly scan and add any new movies. Once that was complete, i clicked a movie and it played with no issues. Now all of a sudden since the new Android 8 has been installed, Kodi no longer checks for updates which was the first 'red flag' that something was wrong, but worse still, it now also doesn't play any of my movies! If i click a movie, one of either 2 things happen, it will just 'load' for a second and then nothing... or, the other thing that can happen is it will try to load it for several seconds, and then freeze. To fix it, i have to click my home button on my remote to get out of the app. I have noticed though, when i first install Kodi, it will play a movie fine, but then the next time when i open Kodi it will play up! I then uninstall it, reinstall, and it works again, for 1 time, rinse and repeat! Very strange...

Now for NOVA (and any other video player such as VLC, or MX). Nova always used to load all my movies for the first time i used the app, and that was the only time it did that, it then would play my movies fine. Now Nova (and this is weirdly an issue with all the other video players) will load every single movie as if the app has just been downloaded! It never used to do this. I have several hundred movies, so this takes a LONG time and has to be done each time i open the app! Once the movies are loaded, it does play them fine though.

Now i've tried a few things to try to fix this. I have factory reset my TV 3 times now, with no change what so ever. I have also re-installed all the video apps about 5 times each now, with no change. I've also cleared the cache, and also cleared the data of each app, with again, no change!

I will just ask, as weird as this sounds, is there any chance my Hard Drive could be causing this?! I honestly don't know why my HD would be causing this, but hey, stranger things have happened lol. I will add, my HD does play my movies, so the HD must be working fine?

Can someone PLEASE try and help me out, i've posted on reddit on both the Android TV subreddit, and the tech support subreddit, but only a couple of people responded and none of them had any idea's other than what i have already tried! I'm at my wits end with it, i literally only use my TV for gaming on my PS4, or watching my own movies, i don't use Netflix or any other app other than YouTube (which works fine), so not being able to use Kodi or any other video player to watch my movies without issues is highly frustrating, and i'm on the verge of seriously buying a new TV if i can't fix this!
 

ASK THE COMMUNITY