Annoying lags and freeze during games

mcqc

Distinguished
Mar 9, 2010
45
0
18,540
Hi everybody, I need your help to fix my computer problem please.
first my system:

GIGABYTE GA-H55M-UD2H
I5 750 2.66GHZ 8MB Quad Core
Sapphire HD5750 1GB GDDR5
Kingston Hyper-X KHX1600C9D3K2/4GX
Western Digital 500gigs
ULTRA LifeTime Series Pro 650W 135MM FAN
__________________
Windows 7 Ultimate 32 bits
Catalyst version: 10.2hotfix


I bought several pieces of hardware a few weeks ago. ^^^^

I have a annoying problem of lag with all the games I tested so far: Far Cry 2, Need for Speed Shift, Crysis. They all run at a decent quality, 45 to 60 FPS recorded with "Fraps" .However I can clearly see the screen froze for a split second every 5-10 second, irregularly depending the games. Fraps does not detect any drop in FPS. Im assuming its trying to load new textures. I try all possible settings: low to high resolutions, Graphics quality from low to very high etc. .. tried different drivers. I even reinstalled Windows 7, but nothing solved my problem.

All my drivers are up to date ... Is this a problem with a faulty graphics card? The ram? The motherboard? Hard disk? The drivers? or else ..

Maybe the "graphic score of "3Dmark06 Advanced editio :love: n 1.2.0" can show you something to compare, I dont know.
http://img708.imageshack.us/img708 [...] mark06.png
http://img690.imageshack.us/img690 [...] ultdta.png
 
Solution
It could be due to you are running a 32bit operateing system that only allows 4 GB of memory now that 4gb is the total with your video card so even if you have 4 GB of ram it will only use 3 because it has to handle the 1 GB of video memory too. I dont know if this is the problem but IMO it prob is. If you went to a 64bit OS it would be able to handle all your memory instead of just 75% of it. Beyond that i dont know why your system would have any problem what so ever considering i run all them games on a E8200 2.66ghz OCd to 3.8GHZ dual core and a 9800GT and i am able to max all the settings out on 1680 x 1050.
It could be due to you are running a 32bit operateing system that only allows 4 GB of memory now that 4gb is the total with your video card so even if you have 4 GB of ram it will only use 3 because it has to handle the 1 GB of video memory too. I dont know if this is the problem but IMO it prob is. If you went to a 64bit OS it would be able to handle all your memory instead of just 75% of it. Beyond that i dont know why your system would have any problem what so ever considering i run all them games on a E8200 2.66ghz OCd to 3.8GHZ dual core and a 9800GT and i am able to max all the settings out on 1680 x 1050.
 
Solution

mi1ez

Splendid
I reckon you have something else running in the background to cause that sort of stuttering at any graphics settings.

Or it could be that you skimped out on the PSU and the graphics card isn't getting enough juice.
 

mcqc

Distinguished
Mar 9, 2010
45
0
18,540

Thanks for the advices SAAIELLO and mi1ez ,
I will run memtest tommorow to see if mY RAM is bad. I forgot to mention something in my first post, I dont played the games with the CD's, I Put all my money on my system so I downloaded those games on the internet to benchmark my computer until I have some money to buy games. Do you think thats why I have problem ?
thanks again
 


I wasnt saying your memory is bad memtest is to find errors in your memoery i just feel that the 32bit OS is limiting the way the system uses the memory. I download most of my games right from EA so i never use cds for my games its faster off your hard drive anyways.

 

mcqc

Distinguished
Mar 9, 2010
45
0
18,540
Thanks you for the good advive about the 64 bits os, I wasnt aware of the difference between the two 0S before that. I will install the 64 bits version on my pc.
I think my hard drive doesnt help either:
Western Digital 500gigs BLACK 32mo WD5001AALS
Did you test this one ?
What Hard Disk do you use ?
 

mi1ez

Splendid

Right, no more help from me.
 

mcqc

Distinguished
Mar 9, 2010
45
0
18,540
Thank you very much,you solved my problem ! My os was the problem. I upgraded to windows 7 64 bit and The games are running perfectly without lags now.