Question Another "NVME 970 evo plus SSD being slow" thread.

Dec 14, 2019
1
0
10
0
Sorry, I tried searching and found other topics with similar questions, but either without solutions or on completely different motherboards where I can't try what fixed theirs.

Specs
i5 6600k
970 evo plus SSD NVME
few other ssds and 1 hdd plugged into SATA
16gb ram
gtx 1070
Asus Z170-A lga1151 Mobo

Just put in the above NVME SSD and I'm hitting really random speeds in Crystal Disk Mark and Samsung Magician benchmarks. How much it varies is worrisome; read speed is okay most of the time.
Write speeds are just completely not okay here.


View: https://i.imgur.com/ZmmmKHT.png

View: https://i.imgur.com/tJyYOFt.png

View: https://i.imgur.com/IZkwHA3.png


I (believe) I have my BIOS to the most current version. I installed the Samsung NVME driver. Windows 10 is a fresh install today. Temperatures are hitting around 60celsius, which I know I've read can cause throttling but it supposedly doesn't happen at that temperature. Others have stated hitting above 60 and having their speeds okay.
And definitely isn't causing anyone else to drop below 2k MB/s write that I've seen.
Benchmarks were around the same as before I filled up 53% of it with transferred files.

View: https://i.imgur.com/dhejkQm.jpg

Here are some BIOS options involving it. I cannot change SATA Mode Configuration from Sata Express to M2, which is what I think is causing it. Whenever I switch from Sata Express to M2 on this option and reboot, computer turns on, crashes within 2 seconds and reboots with Sata Express back in the slot. So if that's it I don't know how to make that work :(

Not sure what I could be missing. Please help.

Thanks.
 

ASK THE COMMUNITY

TRENDING THREADS