ANTEC 300 Power button horrible

IIXxReCoNxXII

Honorable
Jun 21, 2012
27
0
10,530
0
I am using an Antec 300 for a recent build

One thing that greatly annoys me is that almost everytime i push the on button, it gets stuck 'in' and i have to smack the top of my front panel to get it to 'spring back'

I've tried the insides with compressed air and nothing helps.

Does anybody know how i can overcome this?

thanks in advance
 

silvara

Distinguished
Nov 13, 2009
14
0
18,510
0
hmm sounds weird I own three antec 300's and none of them had this problem. You might want so see if something is obstructing the button or maybe try using a plastic safe lubricant very lightly on the area.

If its a new case and the switch is that annoying you mights want to just RMA it. Hope you can get it fixed and good luck.
 

IIXxReCoNxXII

Honorable
Jun 21, 2012
27
0
10,530
0
thanks for the replies guys,

I dont think its worth returning and its only a minor problem.

I will use some plastic safe lubricant on the inside of the switch and hopefully that will fix the problem.

I'm probably going to buy an Antec DF-85 at the end of the year for better cooling/cable management/features etc.

cheers
 

Antec CS155

Honorable
Jul 12, 2012
26
0
10,540
3
Hi there, I'm an Antec Customer Support Rep, please send me an e-mail to vip@antec.com

I can order you a power switch for your Three Hundred case

Thanks
 
Dec 30, 2018
4
0
10
0


I realize this post is really old.

I have an Antec 300 case and the plastic bezel mount for the main power switch failed wayyyyyyy back. The switch itself is not an issue, but that plastic piece that it is mounted into the case with is what I need. Or a way to source it such as description or supplier part number. These have to be somewhat common as lots of computers use that same size style switch.
 

ASK THE COMMUNITY

TRENDING THREADS