Question Anti-Aliasing won't apply to HITMAN

Nov 12, 2022
5
0
10
0
Since my teens I have only played essentially 2 games, one is the HITMAN series (1) and the other is a simulator (2). My GPU is a AMD RX 5500XT (8GB) and my previous CPU was an Intel Core i5-4440. Yesterday I upgraded the CPU to a Ryzen 55600X. When I play (2) everything works fine but with (1) the anti-aliasing won't apply no matter what I do, even though I set the option to maximum value through the AMD control panel and also set everything to ultra in the game. So I see that the problem persists with the new CPU.

Maybe it is useful to say that I was using an old Hard disk with Windows 10 Pro before, and yesterday I changed to a SSD Nvme and installed Windows 10 Pro on it.
 

Karadjgne

Titan
Ambassador
So I see that the problem persists with the new CPU.
Some anti-aliasing is disabled when other settings are enabled to prevent multiple events of post processing or incompatibilities.

There's also multiple types of AA, like FXAA, MSAA, MLAA, TAA, CSAA, EQAA etc and not all of those have x2-x8 differentials, so AA might actually be active, but the x2 or x4 or x8 be disabled or grayed out or ineffective.
 
Nov 12, 2022
5
0
10
0
Some anti-aliasing is disabled when other settings are enabled to prevent multiple events of post processing or incompatibilities.

There's also multiple types of AA, like FXAA, MSAA, MLAA, TAA, CSAA, EQAA etc and not all of those have x2-x8 differentials, so AA might actually be active, but the x2 or x4 or x8 be disabled or grayed out or ineffective.
Ok. The specific term antialiasing or any of the acronyms that you mention do not appear in the settings of HITMAN, but I believe some other option takes care of the antialiasing. Are you suggesting me that I disable one option each time and see what changes? If that is the case, I tried that already with no success :(
What has changed to make you believe that the antialiasing is now not working?
Nothing has changed, the surfaces are still rough (and not smooth as I would expect if AA were in action). However changing:
1- the CPU;
2- the storage device (from hard disk to SSD);
3- clean installation of Windows on the SSD;

and still having the same problem showed me what is not to blame.
 
Ok. The specific term antialiasing or any of the acronyms that you mention do not appear in the settings of HITMAN, but I believe some other option takes care of the antialiasing. Are you suggesting me that I disable one option each time and see what changes? If that is the case, I tried that already with no success :(

Nothing has changed, the surfaces are still rough (and not smooth as I would expect if AA were in action). However changing:
1- the CPU;
2- the storage device (from hard disk to SSD);
3- clean installation of Windows on the SSD;

and still having the same problem showed me what is not to blame.
No I mean did the game look cleaner or better before the cpu change? When you changed your setup did you install all the support drivers from the motherboard maker? Have you double checked to make sure the resolution in the control panel matches your resolution in the display adapter/display settings?
 
Reactions: user1211

BFG-9000

Distinguished
While Hitman is one of the rare deferred rendering games that MSAA actually "works" on, aliasing in this game looks terrible even with supersampling enabled and working.

The post-filter type AA may help more here but can look blurry, and AMD's implementation can cause stuttering and FPS drops. Those are Morphological MLAA for AMD or Fast Approximate FXAA for nVidia, and are set in the driver not the in-game settings.
 
Reactions: user1211

ASK THE COMMUNITY