Jan 6, 2023
Recently I tried to do some editing using Vegas Pro 20 with the help of some friends that knew the program and guided me how to edit in it. I successfully got to edit a small video, not too long somewhere between 12 and 22 seconds I think. The interesting part comes next, I selected render, the video rendered fully, everything all right no issues whatsoever, but I remembered an idea I had to put in the video so here I go again in Vegas while also streaming my full screen on discord so my friends can help me with this idea I had. Vegas opens without any problems, but as soon as I select the project that was saved with all of my progress, Monitor turns black, then my keyboard and mouse and after these go pitch black, the Pc resets. At first I didn't really think it could be a really big issue, maybe my Cpu had a heart attack or something like that but the problem occurred again.

PC starts, I open discord, go to stream my full screen again, open Vegas, select the project I had and boom, the reset happens again. This time in my headphones I could hear i don't really know how to describe it like a relatively loud ZZZZZZZZZ, not too long not too loud but also not too quiet. After this reset, I finally realized that there's an issue with either Vegas or Windows 11 because this friend of mine suggested I should do some benchmarks/stress tests so I can remove the possibility of my Cpu or Gpu or anything at all being bad. Both succeed on their tests, and after this I tried once again to open Vegas but without streaming anything at all on discord. Program opened without any issues, i successfully opened my saved project, got to change some things not too many, and randomly this time the Pc resets again.

After this happened I thought maybe it could be this version of Vegas (Version 20), so I downloaded Version 19, tested it same issue. At this point the probability of it being an Windows 11 issue was very high, but still I wanted to try a final version, Version 18 this time, which both my friends used at that time. I downloaded it, same issue again.
A thing I just remembered is that Version 19 didn't open at all ( which is a problem that a lot of people encountered so I didn't try anything else with version 19 and I got rid of it very quickly).

My PC specs are as follows:
Cpu: R5 3600
Gpu: Rx 570 8Gb
Ram: Team Group T-Force Vulcan Z Grey 16GB DDR4 3200MHz CL16 Dual Channel kit
Seasonic PRIME SNOWSILENT, 80+ Gold, 550 W
Mobo: Gigabyte B450 AORUS PRO
Ssd: Patriot Burst 120GB SATA-III 2.5 inch

Sorry for my Bad English in advance. I can answer any question that could help in resolving this weird issue.