• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question Anyone Else Have High GPU Usage With Edge Browser?

RacAtat007

Distinguished
Aug 8, 2012
206
6
18,695
1
About 6 months ago I switched from Chrome to Edge browser just to try it out and ended up using it as my main browser. Yesterday I noticed my GPU utilization was sitting up in the 60-70% range and spiking almost to 100% with a few tabs open and watching Netflix or YT. It was doing this again today so I looked in task manager and it's coming from Edge. Not sure exactly when this started but sometime in the last week. Temps were mid 60's with just the browser open and this isn't normal, I'm usually around 35-40 at idle. I went back to Chrome and the GPU is back to normal from what I can tell. My main concern is I got a virus or miner or something weird on my PC but nothing is coming back when I run a scan in Windows and Avira. IDK if anyone else even uses Edge but if you do is this happening to you? Current PC specs are below.
 

JWNoctis

Upstanding
Jun 9, 2021
300
59
270
4
I don't watch either myself, but it's probably video decode, or on the off chance some fancy advert or other content utilizing WebGL. Close those tabs with video and see if GPU utilization drops.

Your GPU probably won't be running at nearly max frequency, if video playback at 1x framerate is all it needed to do. It wouldn't do to generate too much fan noise to keep temperature much lower, either.

As of why Chrome is not utilizing your GPU, I have no idea.
 

RacAtat007

Distinguished
Aug 8, 2012
206
6
18,695
1
I don't watch either myself, but it's probably video decode, or on the off chance some fancy advert or other content utilizing WebGL. Close those tabs with video and see if GPU utilization drops.

Your GPU probably won't be running at nearly max frequency, if video playback at 1x framerate is all it needed to do. It wouldn't do to generate too much fan noise to keep temperature much lower, either.

As of why Chrome is not utilizing your GPU, I have no idea.
So this happened over a few days and in task manager I would close out the Edge process using all the GPU and the video would pause a second and resume but the GPU utilization would hop right to another process. This was happening even when I wasn't watching any video, just had edge open on the home page with 1 tab.
 

Colif

Win 10 Master
Moderator
I find usage of either is about 6% GPU but it also depends on what resolution/refresh rate the video is showing at as to how much it uses.
Watching this at 2k uses 33% gpu on my 2070 Super.


If you watching at 4k then I can see it being higher.

Chrome and Edge use more or less same Engine, they both involved in making Chromium so there shouldn't be that big a difference.

Did you try running https://www.hitmanpro.com/en-us and seeing if you are infected?
 

ASK THE COMMUNITY