Question AORUS B450 Motherboard doesn't post, Red Led light on Dram on the board

RedNinja25

Prominent
Feb 25, 2021
5
0
510
0
I recently decided to upgrade my old Mb and Cpu so thats why now i'm really confused why it wont post or anything.
Whats happening when I turn it on is the CPU light turns on, and then it immediately switches to the DRAM Led on the board. For the first 30 seconds it looks like it tries to reboot itself, similar to me pressing the reset switch on the pc. I have tried running only 1 stick of ram in every slot, tried both the 1-2 and 3-4 channels together in an attempt to see if it will boot in duel channel. I have tried to reset the bios by removing the CMOS battery. The only thing I can think of that I don't know how to do is flashing the BIOS with the latest or a newer version as I believe this Motherboard doesn't support the new 5000 series chipsets without an update. I originally upgraded from an Intel i7 2600k so flashing a new bios though an old cpu isn't an option. One last thing to mention is that the ram's RGB does light up, and in fact when I reset the BIOS the RGB was on before I actually turned it on.

Specs:
Cpu: Ryzen 5 5600x
Gpu: Geforce Gtx 1070
Motherboard: Aorus B450 PRO Gigabyte
Ram: Corsair Vengeance RGB Pro 32GB (2x16GB) DDR4 3200Mhz
PSU:600W EVGA 80+ Bronze
Storage: 512Gb Ssd, 512Gb M.2 Ssd, 4tb Hdd
 

ASK THE COMMUNITY

TRENDING THREADS