[SOLVED] Aorus ultra gaming x470 can't use all memory slots

Dec 24, 2018
3
0
10
0
I put together a new build using the following parts:
CPU: AMD Ryzen 1800x
RAM: Corsair Vengeance RGB Pro 64GB 3000 MHz (4*16) (CMW64GX4M4C3000C15W)
Mobo: Gigabyte X470 Aorus Ultra Gaming
PSU: Cooler Master Silent Pro M850

- Windows is showing that only 31.9 GB of 64 GB RAM are available.
- Sisoft Sandra reports single channel mode
- Boot takes long time (boot loop) and resets memory speed to 2166 Mhz, XMP settings are not working with all 4 ram installed.
- Installing only 3 bricks independent of socket configuration works with XMP 3000 Mhz (e.g. Socket 1/2/3 or 2/3/4) also installing only 2 bricks allows full speed and 32/48 GB detected in windows.
- Default Bios settings also cause boot loop with all ram installed.

I know the memory is not listed in the support list of the board but it works fine if used as described above.

I'm wondering if the board is faulty and if I should get a replacement.
 
Dec 24, 2018
3
0
10
0
Thank you for your fast response.
The part number is CMW64GX4M4C3000C15W

The main issue is the fact that windows seems not to be able to use 64 GB. I could live with a lower speed as long it would work.

I'm not sure if the ram is single or double rank (the corsair page does not state it) I tested with all bricks and 1866 MHz but the computer won't boot. The setting bios selects point towards single rank (according to the specs of the CPU)
 

shknawe

Respectable
Oct 22, 2016
1,288
44
2,490
91
If you pull the heat spreader off see if it has sticker with serial numbers on it. It it says like 1rx.... its single rank if it says like 2rx.. then it is dual rank.
 
Ryzen 2000 series CPUs featured an improved memory controller allowing the next higher memory speed over earlier models such as the 1800x. Fact is 3000MHz is not a supported speed with all four memory slots populated.

Corsair lists that as compatible with Intel. If you need 64GB in dual channel, then I think you bought the wrong hardware.
 
Dec 24, 2018
3
0
10
0
I don't want to remove the heat spreader, seems it is glued on. But I tried 2133 MHz which resulted in a boot loop and eventually in only 31.9 GB being available.

Also executed a bios reset with no luck/change. Afterwards I noticed the bios version was set back to F3 (I had updated it earlier to F4d in hope it would resolve the issue)

Updated to F4d again which brings me back to the start.

What Calvin7 stated makes sense. I saw a few posts of people using the Corsair Vengeance RGB Pro together with a 2700x. I gonna get that one after new year and try again. In the meantime I gonna use only 3 modules with 48 GB
 

ASK THE COMMUNITY

TRENDING THREADS