Question Aorus x5v7 - broken beyond repair?

Nov 20, 2022
1
0
10
0
Hi!
I have a Gigabyte Aorus X5v7 laptop that worked just fine until today.

When I bought it second-hand, it had 16gb and 8gb ddr4 memory sticks inside. I did my research and found that the motherboard and CPU support up to 64gb. Why not, right? I bought 4x16gb Kingston ddr4 sticks.

I opened the laptop, removed old memory and installed new one. When I powered up, the screen remained black. Weird, right? I removed RAM from slots 0 and 2 - voila, everything works. Inserted all 4 again - black screen again.
Then it dawned on me - I removed the old memory sticks from slots 0 and 2 without disconnecting the battery first, although the laptop itself was powered off. I tried removing the working sticks from slots 1 and 3 and inserting them in slots 0 and 2. Black screen, although it worked fine in 1 and 3.
From there on, I got some advice to upgrade my BIOS if possible. Didn't find any updates since 2018 (FB12 version) and it seems I have the latest. I loaded default settings in BIOS and restarted.

The black screen still shows up when ever I put memory in slots 0 and 2. I tried every combination possible - old memory in 0-2, New memory in 0-2, one old in either 0-2, one New in either 0-2 etc. Always black screen.

In addition to that, after I defaulted bios settings, it won't let me boot from my m.2 drive. It shows up in bios device list, but not in boot priority list OR Windows my computer section.

Three questions:
  1. Did I fry my 0-2 slots by not disconnecting the battery? How can I test that?
  2. What could I do about the m. 2 drive situation?
  3. Is there really no better version for my BIOS? I could try changing the voltage of my RAM to try and combat the memory issue, I could try and mess around with secureboot, UEFI/BIOS settings to combat the m2 drive issue... But none of these options are available in this prehistoric BIOS!
I'm at my wits end and cannot afford a new laptop. If you have any, ANY suggestions... You would make one random stranger very happy and save him a few months paycheck.

Tried:

*Various patterns of new, old and combined RAM in all of the slots.
  • Removing cmos battery plug and waiting
  • Fiddling around with the very few settings I have available in BIOS.
  • Edit: Checked max memory capacity in cmd and it does report 64gb
Edit v2:
My conclusion:
Since the laptop boots up fine with just 2 of the New RAM sticks, the RAM itself seems to be compatible. It has to be either fried motherboard or messed up settings. Also, all New RAM sticks are same - Kingston, same size, same model, same mhz etc. Basically identical. All of them work in slots 1-3.

I'd hate to sound desperate, but...

A thousand thanks in advance,

Veiko.
 
Last edited:

ASK THE COMMUNITY