Question Apps from Windows Store Wont Work & File System Error (-2147163890)

Jan 3, 2021
13
0
10
0
Ive had these problems for so long now that its just so annoying, and ive tried almost anything i could do to fix it. Whats wrong is that whenever i try to open up an app or game that i have from the microsoft store, it either doesnt open at all or gives me the file system error i said in the title. Apps like xbox game bar, minecraft windows 10 edition, mail, and the xbox app are some of the ones that wont work. And on top of that, whenever i try to open up any file like a video or a photo/ jpeg, it gives me the same "file system error" that i always get, i really need help on this.
 

Colif

Win 10 Master
Moderator
it seems to be a common error for the photos app
edit: removed sfc/dism after seeing you tried that last time i answered.

have you tried the windows update troubleshooter, its on settings/update & security/troubleshoot
additional troubleshooters
should be in top section of next page

there is also a windows store apps troubleshooter on same page. Keep running them until you get no corrections.

notices he has been here before - https://forums.tomshardware.com/threads/file-system-error-2147163890-and-microsoft-store-not-working.3676886/


Hey so i looked through these threads and thry didnt work either. Im also starting to have internet problems in video games i play, an di dont get why because its been fine before. I have a 5g ethernet cable coming from my fathers router too my pc directly but im only now having problems with my internet too, could that also come with my problems? and what other ways are there to just fix my computer. is it maybe a bad app or game i installed or anything? id really appreciate help.
still have internet problems?
what motherboard do you have?

which version of win 10
right click start
choose run...
type winver and press enter
current version is 20H2
 
Last edited:
Jan 3, 2021
13
0
10
0
Hey, sorry for replying late, i ran troubleshooters for both windows apps not working properly and windows updates and both said they couldnt identify the problem, and also i havent been having internet issues anymore so thats fixed, its mainly just file system errors and windows store apps not working now, my motherboard is a MSI B450 Tomahawk Max,
 

ASK THE COMMUNITY

TRENDING THREADS