[SOLVED] are these scores normal for RTX 2080 ti FTW3 ultra

11blackjack11

Reputable
Mar 22, 2015
76
0
4,540
1
First of all, kindly provide FULL and complete specs.
shit sorry now that was just lazy here i think its all there

mobo:ASUS ROG Maximus IX Hero LGA1151 DDR4 DP HDMI M.2 USB 3.1 ATX Motherboard
cpu:intel core i7 6700k
ram:Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz C15
HDD:Western Digital 1TB 3.5" 7200 RPM
SSD:Samsung 860 EVO 2.5
gpu:EVGA GeForce RTX 2080 Ti FTW3 Ultra Gaming, 11GB GDDR6, iCX2 & RGB LED Graphics
psuEVGA SuperNOVA 850 G3, 80 Plus Gold 850W, Fully Modular
 
Okay. Specs are pretty good, but I'm not sure where the problem lies. How does the GPU perform in Games ? Any graphic demanding game ? What is the GPU usage and load under stress ?

How do other Games perform apart from Witcher 3 ? I can't really comment on the Firestrike score, but monitor all the GPU parameters when you play any game, including the TEMP value.

Are you using Windows 10 OS ? Is that a fresh installed copy ? Have you also tried doing a clean re-install of the GPU drivers as well ? Use the DDU tool. What's the native screen resolution of your Monitor, 1080p, 2K, 4K ?
 
Reactions: Phaaze88

11blackjack11

Reputable
Mar 22, 2015
76
0
4,540
1
Okay. Specs are pretty good, but I'm not sure where the problem lies. How does the GPU perform in Games ? Any graphic demanding game ? What is the GPU usage and load under stress ?

How do other Games perform apart from Witcher 3 ? I can't really comment on the Firestrike score, but monitor all the GPU parameters when you play any game, including the TEMP value.

Are you using Windows 10 OS ? Is that a fresh installed copy ? Have you also tried doing a clean re-install of the GPU drivers as well ? Use the DDU tool. What's the native screen resolution of your Monitor, 1080p, 2K, 4K ?
i used DDU tool windows 10 os was a fresh install version 18903
with the witcher 3 i used k boost witch sets it at base clock of 1755mhz on the gpu got temps of 55 and 66 on the cpu gpu usage was 99% dipping down in the 70s i believe got stutters on rage 2 aswell and than the clock speed got stuck at 1300mhz...cards been giving me nothin but issues might RMA it
 

11blackjack11

Reputable
Mar 22, 2015
76
0
4,540
1
So is the GPU faulty ?
with my clock speeds getting stuck at 1300mhz on idle you would think its faulty had to re install drivers for it to go back down to idle clock speeds happened like 3 times already but as for stutters and all im starting to think my 6700k is the culprit here that or the new windows update i did before i got the card i was using version 1803 i believe hadnt bother updating windows for like 4-5 years until now
 

11blackjack11

Reputable
Mar 22, 2015
76
0
4,540
1
Monitor resolution?
Motherboard drivers up to date?
Gpu drivers updated?
Cpu & gpu temps?
monitor 180p 144mhz set it too 120mhz
mobo drivers just updated them
gpu drivers updated with latest one 431.15
cpu temps 67c
gpu temps mid 50s to mid 60sc

was gonna end up playing 4k at some point just wanted to test out how the card was running first but i think my cpu is at fault here 6700k my stock clocks did get stuck but in nvidia panel it was set to maximum performance i set it to default optimal power restarded my pc and it went back to normal my pc did do a weird thing where my monitor went black for a quick second all driveres vanished nvidia panel wasnt even there had to restart my pc and the drivers were back nvidia control panel returned idk maybe my card wasnt seated well had to reseat it
 

ASK THE COMMUNITY

TRENDING THREADS