Artifacts in screen when not gaming.

Jan 4, 2019
2
0
10
0
Hi, im having an issue when there are artifacts in my screen when i am running programs, mainly when i use google chrome. There would either horizontal lines on the screen, half of the screen missing, or the entire screen becomes blank for about a few milliseconds long, and then it becomes normal again for about 5-15 minutes then it happens again. When i am not playing games this never happens. my monitor is plugged in with an HDMI port. Thank you in advance.

GPU: ASUS ROG STRIX RX570
CPU: RYZEN 5 2600
MOBO: GIGABYTE B450M DS3H
 
Jan 4, 2019
2
0
10
0


My RAM is Team Vulcan 16GB 3000mhz running at xmp.
Im running windows 10 LTSC 1809
PSU is a corsair CX550 and i've got it on december 1st, so its fairly new.
 

Ralston18

Titan
Moderator
I lean towards the PSU to be a bit underpowered; however, will set that aside for the time being.

Even new devices or components can be faulty in some manner and start failing either slowly or quickly. PSU's are not at all an exception.


Keep an eye on the Event Viewer logs and Reliability History/Manager.

Look for error codes and warnings that correspond with any particular application/game or combination of applications/games. Google Chrome especially.

Could also be some background app launching and trying to phone home, update, run a scan, etc...

Task Manager and Resource Monitor may also help identify some bottleneck or conflict.

Take your time and watch. Find some constant event or occurrence that corresponds with the display problems. Or some pattern or combination of events.





 

ASK THE COMMUNITY

TRENDING THREADS