[SOLVED] ASRock 970 Extreme4 BIOS issue....

Jake Maverick

Distinguished
Mar 27, 2014
122
1
18,680
0
So I have been having this issue with this board for a few years now. Randomly locks up. Sometimes won't boot at all, sometimes I have to hold down the power button to get it to switch off. So I replaced my BIOS chip, and that fixed it! Then a little over a year it started doing it again and got progressively worse. So new BIOS chip fixed it again...less than year, did it again. I'm on like my 4th/ 5th replacement BIOS chip now and it just started doing it again.....these chips are supposed to last a lot longer? Is this not indicative of something far more wrong with my board? Or is it possibly my BIOS chip provider...well, isn't the best available...?

I really can't afford to replace the board atm. Be struggling to buy a new chip right now tbh....+ I really need a graphics upgrade to 4k, but that seems like a distant pipe dream atm....but while I'm here can anybody recommend a good cheap 4k graphics card?

Many thanks!
 
So I have been having this issue with this board for a few years now. Randomly locks up. Sometimes won't boot at all, sometimes I have to hold down the power button to get it to switch off. So I replaced my BIOS chip, and that fixed it! Then a little over a year it started doing it again and got progressively worse. So new BIOS chip fixed it again...less than year, did it again. I'm on like my 4th/ 5th replacement BIOS chip now and it just started doing it again.....these chips are supposed to last a lot longer? Is this not indicative of something far more wrong with my board? Or is it possibly my BIOS chip provider...well, isn't the best available...?

I really can't afford to replace the board atm. Be struggling to buy a new chip right now tbh....+ I really need a graphics upgrade to 4k, but that seems like a distant pipe dream atm....but while I'm here can anybody recommend a good cheap 4k graphics card?

Many thanks!
i think it is better to disable any overclock, boosts, and everything else, run it at lower voltage for cpu. that's just weird for a bios chip to fail per year as my 9 year old board im using right now is still fine, even after flashing it many time for bios mods testing. it is better to save up money and get an intel 10th or 12th gen cpu, or an amd ryzen 3000 cpu or 5000 cpu/apu. for gpu, anything above 3060 should be good at 4K. Just to remind you that you need a better PSU if you're about to do 4K all game graphics settngs cranked up.

*My friend does more worse, he replaced 3 Boards over years until now he decided to go intel and ryzen, and everything fine 24/7 rendering, i guess it's an Amd FX mobo issues.
 
So I have been having this issue with this board for a few years now. Randomly locks up. Sometimes won't boot at all, sometimes I have to hold down the power button to get it to switch off. So I replaced my BIOS chip, and that fixed it! Then a little over a year it started doing it again and got progressively worse. So new BIOS chip fixed it again...less than year, did it again. I'm on like my 4th/ 5th replacement BIOS chip now and it just started doing it again.....these chips are supposed to last a lot longer? Is this not indicative of something far more wrong with my board? Or is it possibly my BIOS chip provider...well, isn't the best available...?

I really can't afford to replace the board atm. Be struggling to buy a new chip right now tbh....+ I really need a graphics upgrade to 4k, but that seems like a distant pipe dream atm....but while I'm here can anybody recommend a good cheap 4k graphics card?

Many thanks!
i think it is better to disable any overclock, boosts, and everything else, run it at lower voltage for cpu. that's just weird for a bios chip to fail per year as my 9 year old board im using right now is still fine, even after flashing it many time for bios mods testing. it is better to save up money and get an intel 10th or 12th gen cpu, or an amd ryzen 3000 cpu or 5000 cpu/apu. for gpu, anything above 3060 should be good at 4K. Just to remind you that you need a better PSU if you're about to do 4K all game graphics settngs cranked up.

*My friend does more worse, he replaced 3 Boards over years until now he decided to go intel and ryzen, and everything fine 24/7 rendering, i guess it's an Amd FX mobo issues.
 

Jake Maverick

Distinguished
Mar 27, 2014
122
1
18,680
0
Thanks!
Nothing is over clocked though...and I did get a 4k graphics card last year...the math added up for the psu, but close. in theory it should have been ok...i thought the card was faulty and sent it back...then started having this problem, had to switch out bios chip again...and ran fine for about 8-9 months until it started doing it again. Have upgraded my PSU now...but yep it is weird! I was thinking something up with the mummyboard, so have been looking for like for like replacement. But apart from this problem occurring now and then, the rig runs absolutely fine! Just no income atm, very skint....so can't afford to upgrade. + I was looking for like for like as i didn't want to have to re-install entire system again, it's triple boot and pretty complicated set up....
 
Reactions: Koekieezz

ASK THE COMMUNITY