Question ASRock 970 Pro3 R2.0 won't boot after UEFI reset

Mar 6, 2019
6
0
10
0
Hi,

I had a running system, which I attempted to overclock. Since I'm an idiot who doesn't know what he's doing, I changed the maximum CPU frequency from its default (I think it was 150Mhz) to 350Mhz. The computer booted to a black screen so I was forced to reset the UEFI using the old jumper technique. After this I have been unable to boot off my SSD drive, no matter what I tried. Here's the details:

I installed an ASRock 970Pro3 R2.0 (2.8 UEFI version) and connected a Crucial MX500 Sata SSD drive. One of those M.2 ones. Because there's no M.2 connector on the motherboard, I bought a very cheap M.2 to Sata converter board which worked fine. Installed Windows and everything, ran it for about a week, rebooted a bunch of times (it's so nice and quick I rebooted for fun sometimes).

Then, after playing Elite Dangerous I figured I could use some CPU overclocking (an AMD FX-4300). I did that because my mouse was sluggish and I hadn't found any other solution. The overclocking went bad. The system booted to a black screen, so I reset the BIOS to defaults using the jumper. But my system never booted from the SSD again. It just freezes. Each time, no matter what I try.

I've been able to boot my machine from a USB stick, running the Windows10 installation and repair tools. From the command prompt I can access the Crucial SSD just fine, chkdsk says it's ok, Windows can't repair it, I've run bcdboot c:\Windows on it, formatted it, reinstalled Windows on it, you name it. Nothing seems to get the SSD to boot.

Edit: I've disabled CSM and Secure boot. Nothing seems to make a difference.

Right now, I've set the Sata controller back to IDE mode (from AHCI mode) and reconnected my old, tired Sata HDD. Ran bcdboot on that and now I can boot again. The Crucial SSD drive is now installed as a regular data drive, which works just fine.

I've run out of ideas. Does anyone have a clue what could be the problem? Could it be that the UEFI keeps a copy of a profile for booting from the Crucial SSD? Do I need to take the battery out to resolve this? Or should I just buy a regular Sata SSD drive and install Windows on that?

Please help.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS