Question AsRock A320M-DGS stays on boot screen after bios update

Mar 28, 2019
4
0
10
0
HI there .



i have (just) bought a AsRock A320M-DGS.
made a build and got it all to work nicely. did all the win 10 updates and mobo drivers in place.
The only thing i needed then was to update bios. so i did.. i went from 1.10 to another (think it was 2.50) and then moved on to 3.40 - no problem all worked fine .. THEN i moved on to 4.40. all frozen on loadscreen. see pics.

my pc stops at load screen. (se pics). only TAB works now which only gets me to see the bios version. (2.nd sec of pics)

i have tried 4 times to clear CMOS. i think now in 4 different ways ;-) - but nothing works.

so .. now i cant acces the pc in anyway now. hmm


first screen:

View: https://imgur.com/25h7muF


View: https://imgur.com/kGtXyS1




after pressing TAB (which is the only button that works) i get this screen.

View: https://imgur.com/rKEfGkR


View: https://imgur.com/bkto8AQ




pls help me!

thx

btw : cpu is AMD A8-9600
 
Mar 28, 2019
4
0
10
0
sure? i can reuse other parts? i mean it was a bios update (so its not the cpu that is [censored] broken?) (not expert) ;-) btw thx
 
Last edited by a moderator:

McKeu

Proper
Mar 27, 2019
240
28
140
6
Do you have the possibility to get another compatible CPU for testing?
Reset CMOS once again before and let it retrain with the new CPU. Other than that the mainboard might be irreparably damaged, unless you find someone to replace the BIOS chip for you. And even that is not guaranteed to fix it, as other components on the board might have died along the way.

EDIT: also test with other RAM, just to be sure.
 
Reactions: mads2205

ASK THE COMMUNITY