Question ASRock A320M-HDV issue

Oct 5, 2020
2
0
10
0
My ASRock A320M-HDV stopped powering up external HDD s, smaller things like usb drives the usb ports read without problems. What could be the cause?

My ASRock A320M-HDV stopped powering up external HDD s, smaller things like usb drives the usb ports read without problems. What could be the cause? Haven't come across any one with my situation, need help.
 
Last edited by a moderator:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Make sure you're on the latest BIOS update for your motherboard and also on the latest version for your OS. Are you sure the external HDD's work on a donor system? If so, might want to try the rear USB ports and in doing so, make sure your chipset drivers are reinstalled.
 
Oct 5, 2020
2
0
10
0
Welcome to the forums, newcomer!

Make sure you're on the latest BIOS update for your motherboard and also on the latest version for your OS. Are you sure the external HDD's work on a donor system? If so, might want to try the rear USB ports and in doing so, make sure your chipset drivers are reinstalled.
I haven't updated bios yet, im using the rear USBs, anything that requires a bit of power the USB 3.0 do not read jus the LED light of the external drive responds but won't spin, even on phones, some of them won't charge. Might it be a PSU issue?
 
It might well be a problem with the +5V rail on your PSU.
You could check voltages in HWiNFO64 (keep in mind that values from the sensors might not be accurate). Run it in the Sensors only mode and check voltages on your +3.3V, +5V and +12V. The +5V is the one that matters more in your case... you can plug a USB device in and check how the voltage reading on the +5V changes.
You could also check voltages in your BIOS.

We also need full system specifications: motherboard, CPU, GPU, RAM, PSU, Case.
 
Last edited:
Reactions: sYzZNo

ASK THE COMMUNITY