Question ASRock A320M-HDV with ryzen 5 3400g keeps crashing ?

GmMMM

Honorable
Oct 28, 2014
4
0
10,510
0
Hi, pc store around the corner built me a PC, it was ryzen 5 3400g with asrock a320m-hdv mb, it has been crashing since day one first bsod but a driver update fixed that, then it went onto random freezes when my kids play roblox or minecraft ... now when it crashes (freezes) and we need to reset it starts up without drivers installed, weird? what could be causing the system to uninstall drivers? "No AMD graphic driver is install", and I have to reinstall it again, the radeon software that is in the taskbar disappears as well, weird no?

Anyway 4th time I took it back I suggested it maybe the bios (I am doing all the leg work, they don't seem to have a clue) so they updated it to 4.0 but the same thing happens, crashes about 30 or so minutes into minecraft and when reset the drivers have disappeared. I am really lost what to do, the people at PC store seem sick off me but I brought a PC from them and told them it is for my kids top play minecraft and roblox and it doesn't do that without freezing. ANy ideas why it keeps crashing? It is hard to find information searching, but some people online say bios 4.0 not ok either even though asrock site apparently says it does, that what computer guy told me,
 
Last edited:
Hi, pc store around the corner built me a PC, it was ryzen 3 3200g with asrock a320m-hdv mb, it has been crashing since day one first bsod but a driver update fixed that, then it went onto random freezes when my kids play roblox or minecraft ... now when it crashes (freezes) and we need to reset it starts up without drivers installed, weird? what could be causing the system to uninstall drivers? "No AMD graphic driver is install", and I have to reinstall it again, the radeon software that is in the taskbar disappears as well, weird no?

Anyway 4th time I took it back I suggested it maybe the bios (I am doing all the leg work, they don't seem to have a clue) so they updated it to 4.0 but the same thing happens, crashes about 30 or so minutes into minecraft and when reset the drivers have disappeared. I am really lost what to do, the people at PC store seem sick off me but I brought a PC from them and told them it is for my kids top play minecraft and roblox and it doesn't do that without freezing. ANy ideas why it keeps crashing? It is hard to find information searching, but some people online say bios 4.0 not ok either even though asrock site apparently says it does, that what computer guy told me,
Most crashes of otherwise healthy system are caused by overheating. For first aid, uninstall graphic drivers using DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
Download and install drivers from https://www.amd.com/en/support , choose Processors with graphics > AMD Ryzen processors.
 

GmMMM

Honorable
Oct 28, 2014
4
0
10,510
0
Most crashes of otherwise healthy system are caused by overheating. For first aid, uninstall graphic drivers using DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
Download and install drivers from https://www.amd.com/en/support , choose Processors with graphics > AMD Ryzen processors.
Not over heating, can run stress tests for hours and they all run fine. What I can't understand is when it crashes the drivers and the AMD software gets uninstalled so every crash it means a reinstall, anyone have any idea why this happens?.

I now believe after some research it is a incompatibility problem with ryzen 3 3400g and the asrock a320m-hdv motherboard. Some people have success with downgrading the bios to 3.3 but this should even need to be done, asrock should remove ryzen 3 3400g from it's listed supported chips for the a320m-hdv motherboard as it seems I am not the only one with problems.
 
Not over heating, can run stress tests for hours and they all run fine. What I can't understand is when it crashes the drivers and the AMD software gets uninstalled so every crash it means a reinstall, anyone have any idea why this happens?.

I now believe after some research it is a incompatibility problem with ryzen 3 3400g and the asrock a320m-hdv motherboard. Some people have success with downgrading the bios to 3.3 but this should even need to be done, asrock should remove ryzen 3 3400g from it's listed supported chips for the a320m-hdv motherboard as it seems I am not the only one with problems.
Honestly, a320 MBs are crap, specially with later CPUs, their (and most 300) series poor handling of memory do not help at all. You'd be muchh better off with worst b450/550 than best A320.
 

ASK THE COMMUNITY