ASRock A320MPro4 / AMD Ryzen 2400G build - Boot problem

Sep 28, 2018
1
0
10
0
I'm building a system with the following spec:

MB: Asrock A320M Pro4
CPU: AMD Ryzen 2400G
Memory: Corsair Vengeance LPX CMK16GX4M2B3000C15
SSD: ADATA SX800/960GB
Power supply:650W

Monitor attached to onboard VGA port. System appears to start OK, and goes into BIOS settings after pressing f2 on keyboard. Temperatures all seem OK on bios screens. After about 15-20 seconds the screen goes blank, but PC appears to stay running (fans still on, power light on).

Pressing the power button for 5 seconds, to turn off, and then turn back on, now the PC appears to start (fans & lights), but nothing appears on screen, and after 15-20 seconds the PC restarts, and it continues going through the statup/reboot cycle.

Leaving the PC for a few hours, and I can go back to a proper boot and see the BIOS screen again (for a few seconds).

The only beeps from the motherboard speaker are a single beep as it goes into BIOS settings. No other indications of errors.

I've reset the BIOS, but no change.

I've removed both RAM sticks, and I don't even get warning beeps on system start, which seems strange.

I don't have access to any similar components to swap out, so really not sure what's at fault here. Any advice for how I can try and diagnose the problem?
 

julienruc

Respectable
The problem is that you have a 2nd generation Ryzen CPU and most A320 Motherboard are still on older BIOS versions, which do not support 2nd Gen Ryzen CPUs. They need to be updated to one of the latest BIOS versions before they can read 2nd Gen CPUs.

Most boards will be updated already upon purchase, but some of them aren't. Check if your Motherboard says that it's Ryzen 2nd Gen Ready. If not, you'll need to find someone with a 1st Gen Ryzen CPU to update the BIOS to latest version first or bring it to a store that can do it for you.
 


If BIOS version was the culprit the OP wouldn't be able to reach the BIOS at all-something else is amiss here.
OP: do you lose signal just by staying on the bios or when you're trying to load windows? Have you tried a single ram stick at a time? Have you tried perhaps a different display cable/connection/monitor?
 
Dec 18, 2018
1
0
10
0
This is a very common problem with AsRock boards in conjunction with Ryzen processors. I recently had this exact same issue with an R5 2600/AsRock AB350M gaming itx board. After days and days of troubleshooting every other component, a few Google searches on the motherboard and I find out that this is a known problem with using AsRock w Ryzen. I RMA’d the original board and had the same problems with the replacement. I then replaced it with an MSI board and haven’t had a problem since. Again, not just my experience - there are quite a few threads on this around the internet with nearly all of them being solved by using a different brand of board. There’s a 33 page thread about it on the AsRock forums. Your results may vary, but the first thing I would do is get another brand of board and save yourself a few days/weeks of annoyance.
 

ASK THE COMMUNITY

TRENDING THREADS