ASRock AB350 ITX Ryzen 2200g wont post no display new build

Sep 12, 2018
1
0
10
0
I have searched high and low to the solution to my issue here to no avail. Hopefully someone can help.

Build list:
CPU - AMD Ryzen 2200G
CPU Cooler - Noctua Low Profile
Motherboard - "RYZEN 2000 READY" ASRock AB350 Gaming-ITX/ac (BIOS 4.60)
Memory - G.Skill Ripjaws V (2x4GB) DDR4-3200
Storage - Micron 1100 256GB M.2 2280 SATA III
Case / PSU - Mini-Box M350 and picoPSU-150-XT/12V 12.5A 150W AC-DC

ATX power is a 4 pin..motherboard is 8 pin. I have tried another 450W power supply with the 8 pin and I am getting the same results.

The CPU Fan spins and PLED lights up, but no display.

After some research I have tried the obvious checking the bios update to make sure my mobo can run Raven Ridge. Sticker on my mobo says P4.60 so I should be ok there. I called ASRock to make sure it was correct, and they walked me through a few steps which included resetting the cpu, unplugging the CMOS, booting with just 1 RAM stick...and the tech came to the conclusion that the board was shorted out somewhere. I sent the board back and got my replacement today, and I am running into the same issue. The PC powers on..CPU Fan spins and LED lights up, but no post beep from the speaker I plugged into the motherboard, and no display on my monitor.

I am plugged into my monitor using HDMI -> DVI.

Any help is greatly appreciated.