Question Asrock B450 Steel Legend - Multiple Storage Issue

bopytorrefranca

Commendable
Mar 7, 2018
9
0
1,510
0
Hello there,

I have a Ryzen 5 3600 & a ASROCK Steel Legend B450 Setup here. I am having this issue since I built this PC back in March.


The Setup:

M2_1 Slot
________________Installed M.2 SSD
SATA3_A2 ____has 1TB HDD
SATA3_A1
________________has 1TB HDD

--------------------------------------------------

My Problem:

How do I properly enable my 2 Hard Drives to be visible in Windows? When I go the Disk Management, both Hardrive1 and Hardrive 2 are shown. But only, Hard Drive 1 ( Disk 0 ) shows.
Also, both of the drives are being read as Removable Device. I have tried the Hotplug config found on some randon videos on Youtube, But it will only let 1 Drive to be read as Internal and the other still on Removable Device. Help , thanks y'all!
 

Lutfij

Titan
Moderator
Once you powered up the system and installed the OS, did you install the chipset drivers for the platform? You can find them off of your motherboard's support site or from AMD's support site.

Mind showing us what you're seeing in Disk Manager and on your taskbar with regards to the removable devices? Also, which BIOS version are you working with for your motherboard? Version for the OS?
 

bopytorrefranca

Commendable
Mar 7, 2018
9
0
1,510
0
Once you powered up the system and installed the OS, did you install the chipset drivers for the platform? You can find them off of your motherboard's support site or from AMD's support site.

Mind showing us what you're seeing in Disk Manager and on your taskbar with regards to the removable devices? Also, which BIOS version are you working with for your motherboard? Version for the OS?

I am on Windows 10 Home 64bit with UEFI Version B450 Steel Legend P3.20


I have these drivers installed, please let me know if I still have drivers missing.
 

ASK THE COMMUNITY