• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question AsRock B450 stuck on boot loop please help!

Jul 9, 2020
1
0
10
0
System turns on with no display doesn’t get to post, then after about 20 seconds it powers down and reboots repeating that process. We’ve been working on it for two straight days. We’ve tried stripping it back to the essentials (only motherboard and CPU etc) and resetting the CMOS to no effect. I’ve tried multiple Graphics cards, display connectors and power supplies with no change. I have no other AM4 CPU to try but the one I have is a brand new Ryzen 5 3600 that appears to be in fully functioning order. I have also tried a number of different forms of memory in various co-ordinations across the four slots, again to no change. The motherboard bios is V: 3.20 so should be compatible with Ryzen 5 3600. Is my Motherboard faulty, should I return it, or am I missing something?

PARTS:

Motherboard: B450 Steel Legend
CPU: Ryzen 5 3600
GPU: GeForce RTX 2070 Super
Power Supply: Seasonic S12-650 III
Memory: 8GB PC4 1.2V
Storage: 500gb WD Blue 3D NAND SSD M.2 2280
 
Last edited:

ASK THE COMMUNITY