Question Asrock B550 Steel Legend Realtek LAN port issues?

Jun 18, 2022
1
0
10
0
My PC has started having LAN port issues. I cannot use an Ethernet cable and the ethernet port on my B550 Steel Legend board with my R7 3700X. This port originally worked, but several months ago, it randomly stopped. I assumed it was some weird windows update that broke it, but I still cannot connect via ethernet.
My ethernet cable works, I tested it with my sibling's PS4. When I have an ethernet cable plugged in, nothing shows up under network and internet settings - as if it doesn't register something is plugged in at all. My initial thoughts was that this wasn't hardware related (as it worked a few months ago, and my computer had not moved from the desk it was on prior to having issues).

My specs are:
  • ASROCK B550 Steel Legend ATX
  • AMD Ryzen 7 3700X 8-Core Processor
  • Crucial Ballistix sport 3200 MHZ
  • AMD 6700XT reference
  • SK hynix Gold S31
  • intel AX200 m.2 wifi
What I've attempted thus far: Updated BIOS to most latest on ASROCK's site for my mobo, checked for windows updates, checked for GPU updates, checked AMD chipset updates, attempted uninstall and reinstall of realtek drivers and dragon ASOCK drivers for mobo multiple times, checked through device manager (and have not seen any indication of LAN there), updated MOBO chipset drivers, ensured Deep Sleep mode in BIOS was disabled, verified LAN was enabled in BIOS, unplugging PSU and holding power for 30secs to clear capacitors, and attempted to manually add the realtek LAN driver via device manager (although there was no realtek option when going through action>add legacy hardware>adv>network adaptor> no realtek driver was found).

The LAN port had worked previously but randomly stopped working it appears. I thought it was because my BIOS needed updating, but this doesn't appear to be the case. The ethernet cable works fine in other devices as well. On the ethernet port, I see a yellow solid left light and solid orange light on the right which seems to indicate "On/Linked" and "100Mbps/1Gbps connection" per https://download.asrock.com/Manual/B550M Steel Legend.pdf page 10.

Below are some images of my device manager (before and after attempted realtek LAN drivers are installed), MSINFO information, and the Realtek driver install (and subsequent error). View: https://imgur.com/a/hB7JPgu

I'm really at ends here as I have no idea where to go next. Any ideas?

I've tried troubleshooting found here (
View: https://www.youtube.com/watch?v=EGJKKb0_Gpk
,
View: https://www.youtube.com/watch?v=-cHIkHx-eXw
,
View: https://www.youtube.com/watch?v=8ZSIKL6Wu1o
) to no avail.
 
I agree try the linux usb boot first.

This unfortunately is what a bad port looks like. I had a bunch of machine damaged by a lightning strike...all my equipment is on UPS an surge protection. The ethernet ports look fine but OS does not see the device.

Luckly a PCIE ethernet card is fairly cheap. If you do not have room in your machine you can use a USB ethernet adapter but be sure to get USB3 so you get gigabit speeds.
 

ASK THE COMMUNITY