Question Asrock B550M Pro4 boot issues. CMOS/PSU related??

Apr 10, 2021
NOTE: Kind of a long post...

Back in mid Feb I built a system using a B550M Pro4 motherboard(I'll post the full specs below) and I'm having a weird issue with it not posting at all (Like there is no power hooked up.

I'm going to start by saying my computer is on pretty much 24/7as I run some local server stuff on it for things around the house so it is on pretty much non stop. I first built it and it worked great for about a month and a half and one day we had a random power outage here in the middle of the day. Not sure how long the power was out but I tried to reboot my computer and nothing and of course I freaked out but I unplugged my power supply and let it sit while I turned my kids computer back on (Asrock B450M Pro4 with a EVGA psu) and that worked great, came back on with no issues.

I went back to mine and plugged it back in and it booted up just fine and I didn't really think much of it after that until about a week later my computer just hung on me and wouldn't even shut down to reboot so I pulled the power and same thing, it wouldn't reboot at like the PSU stopped working. Well, it in fact did, kind of. I removed power and let it site for about an hour and then it turned back on like normal and 15 minutes later, it hung again. Turns out I was loosing power to the sata cable and other issues from the PSU. So I contacted the company (GameMax), they sent me a new PSU and it worked great, aside from the very faint burnt electronic smell from the replacement one, as it should, for about 3 days, and now, the system runs great but if I try to reboot it, I have similar issues again and this is whats going on...

With the new power supply for about 3 days, it would reboot and start up as normal but now, it will act like there is zero power going to the motherboard (No lights or anything come on) and the power button does absolutely nothing if I shut it down and try to restart it right away or do a restart in windows, unless I pull the CMOS battery and clear the CMOS. Once I do that, BAM! computer starts up just fine and works great, that is until I attempt to shut it down, and end up having to remove the power to get it to actually shut it off 100%.

It will go through the whole shut down, shut windows down, but the computer will stay on and the CPU fan will ramp up to full speed a few seconds after windows shuts down and my monitors go black (About the time the system should actually power down completely) and I have to unplug the PSU from the wall (Or flip the switch off), and to get it to reboot again, I have to either let it sit for a while, unplugged, or clear the CMOS and then it will boot back up like normal.

The replacement PSU will turn on and off just fine with just the 24 pin hooked up with the test jumper to turn the PSU to test it (The old one didn't) but if I hook it back up to the motherboard right away, I get nothing, unless I clear the CMOS. I have another new PSU on the way (An EVGA PSU) and some motherboard speakers so I can see if there is any beep codes and will try that but I hope its nothing to do with the motherboard or something more like the CPU or something. This whole thing started when we had that random power outage and the power supply went all wonky and now this is beyond frustrating.

-Asrock B550M Pro4 Motherboard (Original and current Bios vP1.10. Dont know if an update would help or not)
-AMD Ryzen 9 3900X CPU
-32 gigs G.Skill Trident Z RGB 3600 (I know its not on the approved list but when its dialed back to 3200 it runs great and zero issues. And I'm still having issues with approved memory from my kids computer)
-EVGA GTX 1070 SC GPU (Yeah I know but I can't justify paying current GPU prices so working with what I have and its working fine for me until GPU prices become realistic again)

-GAMEMAX RGB 750 (750 Watt) PSU (Going to replace with a EVGA Supernova 750 watt PSU as soon as it shows up)

Any ideas would be great with getting this thing fixed. And yes, I have tried powering things on with no GPU, hard drive, RGB case fans, etc... plugged in and zero change. Some reason my CMOS is getting all messed up or something when I attempt to power off/reboot the computer. I have not tried to hard power off (holding the power button while powered up) and restarting it that way yet. I'll report back any finding a long the way as well. Thanks.

Update since I started to write this up: I have since tried installing a new EVGA SuperNOVA 750 PSU and no change and also reflashing the bios with no luck. Still doing the exact same thing. I really really hope this isnt CPU related. I also have a new Asrock B550M Pro4 motherboard on the way but it wont be here for a few days. In the mean time I would really love to try and figure this out.