Asrock Conroe1333 -D667 and Radeon HD 5770

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
Hi all,

I recently bought a sapphire hd 5770 and it wont work with my mobo! i thought it would have been my psu because it was a 500 watt one worth £10- 15. So i bought a corsair 650 watt psu worth around £80. installed it plugged it in and still no luck! i dont get any POST! I ended up trying the card in my mates PC which is a dell (and has a 375 watt PSU btw) and it worked perfectly on his pc! i was very confused so then i knew it has something to do with my mobo, so i contacted asrock and they told me to update my bios to 1.83. I checked their site and the latest bios update on there was 1.80 which i already have installed! after carefully re-reading the e-mail they sent me i realized they attached the update 1.83 so i was pleased. After downloading it, i tried to run it but didn't have any luck because it was an 'unknown application'... it says that its a file type : 83 File. Any idea how i can get this to work so i can install it? my mate says that it 'sounds like firmware' but because i have so little experience i had no idea what to do but ask on here. So can anyone help me out?

Thanks for your time,
Funk.
 
What's the complete file name that was attached to the email and how large is it? Your manual should indicate how to update the BIOS, but you can also find instruction at ASRock: http://www.asrock.com/MB/download.asp?Model=ConRoe1333-D667%20R1.0&o=All

Click the + icon that corresponds to the OS that you'll be using (DOS or Windows). The link above is for version 1.0 or the motherboard (you didn't specify if yours is 1.0, 2.0 or 3.0), but the instructions are the same for all versions.
 

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
yes my mobo is version 1.0 and is updated to bios v 1.80. the file name i got from Asrock was called CR13D6_1 the instructions when i click the plus sign are for an exe file which i followed when installing bios 1.80 but for some reason this isnt like the other files on the net which is weird.
 
If ASRock support didn't provide instructions, e.g., rename the file to its correct name, contact them again and ask them for the missing instructions. If you know how large the file is, then it's relatively easy to determine what it is. You could also inspect it's contents to make sure that it's a BIOS file.
 

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
i cant inspect its contents, i dont know how to. and contacting asrock would only result in me waiting another 2-3 weeks before i get a reply...
 

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
oh and btw, the file is about 512 kb so its not large i think all the downloads from the site are roughly this big but they are exe and not some weird file format :??:
 

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
hmm managed that and when i click on the file now it opens cms prompt for a split sec then closes it and nothing happens :S maybe its meant to be a diff file type? also i think the .83 might have been an error on asrock's behalf (god i hate that company) because they names it 1.83 at the end as in bios 1.83 and it understood it as a .83 file. i tried .zip and .rar but no luck i cant extract it. any ideas?
 

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
oh wait i just downloaded the 1.80 from the site and it has an exe file opening a system file that has the exact name as the file i downloaded from the e-mail! it is called CR13D6_1.80 instead of 1.83 so all i need to do is make an exe that will open the 1.83 system file and i might be able to install! if only i knew how too :p
 
Then they only provided the BIOS file and not the tool to flash the BIOS. Don't you have a tool to flash the BIOS? I haven't worked on an older ASRock motherboard, but they are not that difficult to flash. If need be, download the DOS (preferred) or Windows utility to flash it.
 

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
i just figured out that this is a way to setup the DOS. if i downloaded the 1.80 DOS setup version of 1.80 i get the same file and an exe. apparently the exe can run any of the files so its not set to a specific one aslong as i type the file name. but the thing that annoys me is i have to do it via floppy drive...

»Updating BIOS Procedures:
1- Create a bootable system floppy disk.

2- Download an updated ASRock BIOS file (WinZip format with .zip file extension) from the web site, unzip the BIOS file and save both ASRFLASH.EXE utility and BIOS file to the disk you created in step 1.

3-Boot from the disk you created in step 2.

4-At the "A:\" prompt, type ASRFLASH, hit space bar once, and type BIOS file name then press <Enter>. For example: A:\ASRFLASH K7S41GX2.00 <Enter> then you will see a message "Please wait for BIOS loading ROM".

5-After 30 seconds, you will see the message "Flash ROM Update Completed - Pass", then you have finished upgrading the BIOS.

6-After finishing upgrading the BIOS, please remove the floppy disk. Restart your system and press <F2> to enter the BIOS setup utility during boot up.

7-In Exit menu, please select "Load Default Settings" and press <Enter> to continue.

8-Select "Exit Saving Changes" and press <Enter> to exit the BIOS setup utility.

9-Now, system is booting up with new BIOS.

Now to find a floppy from God knows where and learn how to make a bootable system floppy disk...
 

funkmeister 3000

Distinguished
Feb 2, 2010
10
0
18,510
bingo, managed to install it via windows Dos mode and it works, graphics card works excellently and I am now pleased... But im never buying an Asrock ever again...
 

itgadgets

Distinguished
Feb 6, 2010
4
0
18,510


Hi there,

I am also having the same issue with a 5750 card and a ConRoe1333-D667!

Would it be possible to email me bios 1.83?

cheers

Scott
 

Heavy88

Distinguished
Feb 7, 2010
5
0
18,510
Hallo,

Is it possible to upload the Bios on rapidshare or somewhere else?
I need the bios for my system

Thx

Mike
 

itgadgets

Distinguished
Feb 6, 2010
4
0
18,510
Hi Mike,

I am still waiting to get hold of this bios update!

I have a request in with Asrock and my supplier....

If/when I get it I will let you know!

cheers, Scott
 

itgadgets

Distinguished
Feb 6, 2010
4
0
18,510
Mike I now have Bios 1.83 (Dos & Win)

I have yet to try it as the pc is at my folks place, will be getting done tomorrow!

Send your email address and I will forward you the files...

cheers, Scott
 

tomtop

Distinguished
Feb 10, 2010
1
0
18,510

Can you please send me the Bios update to 1.83 to my email plz. ter0211@hotmail.co.uk
thx alot :)