Question Asrock Extreme4 970 BIOS Instant Flash not working

Jul 23, 2019
2
0
10
0
I’m trying to update my BIOS , but for some reason the Instant Flash won’t detect its own file. I instant Flash, It scans and shows the file, but doesn’t seem to know that’s the instant flash file, (970EX2.80) and it sits there, as it just does the same thing to other non instant flash files , which I know because this USB wasn’t empty the first time I tried it. I have an Asrock Extreme4 970 . I bought it used and I’ve only had it for a few months (I understand I shouldn’t touch the BIOS if everything is working correctly , but the problem I have is the USBs disconnecting when there is a heavy load, specifically when using Adobe Premiere. They disconnect randomly, and there’s no way to get them back working so I’m forced to restart each time. So from my research I found updating the BIOS has fixed this for many people.) I’ve tried 2 different USB sticks and an external hardrive , and formatted both USBs over multiple times. Any help would be greatly appreciated!
 
Jul 23, 2019
2
0
10
0
You can order a BIOS chip on ebay and replace the board's one.

Oh cool...I may check that out then, thank you. I've cleared the media cache on Adobe Premiere and also noticed my external hardrive wasn't plugged into the 3.0 port. Now it seems to be fine. I'm going to get a fast SSD to make even more sure, because the problem only persist and is only subject to randomly happen while loading up media from all the Adobe Premiere projects from this hardrive. After it's loaded and successfully does it without disconnecting the USB's, everything is fine. The whole USB disconnecting problem only happens with Adobe Premiere so yea. If that's fixed I wouldn't need to touch the BIOS. Even though I still have no idea of why the Instant Flash doesn't work
 

ASK THE COMMUNITY

TRENDING THREADS