Asrock fatality 990fx killer motherboard bios update failed now black screens

Nov 8, 2018
3
0
10
0
tried to update my bios and the update failed and my pc decided to restart anyway now all It does is starts and runs everthing looks and sounds like its working but the screen never boots up just stays black how can I fix this
 

Darkbreeze

Titan
Moderator
Usually, this means the motherboard is bricked and must be returned to ASRock to have the bios flashed using special equipment or to have the bios ROM replaced. Some boards have replaceable bios ROMs but you'll have to contact ASRock to find out if yours is and if they are still available on a board this old.

Prior to that, you can TRY to reset the CMOS hoping on a long shot that it might work. Doubtful, but worth a try. Unplug power. Remove the cmos battery for five minutes. Press the power button for 30 seconds during that five minutes. Then put the cmos battery back in, plug in the power and power up. If there is still nothing, you will need to contact ASRock or purchase a replacement motherboard.
 
ami and award bios do have bios recovery if the bios bricks if your lucky and the bios is trying to recover itself. if you tried to update from inside windows then the bios may still have a good recovery boot block. from another pc download the bios and put it on a usb stick on the root of the stick and not in a folder. AMIBOOT.ROM.
Turn On the system and press and hold Ctrl-Home to force update. It will read the AMIBOOT.ROM file and recover the BIOS from the A drive.

When 4 beeps are heard you may remove the floppy disk and restart the computer.
 

ASK THE COMMUNITY

TRENDING THREADS