AsRock FM2A85X-ITX not detecting HDDs

Tweedledum

Distinguished
Jun 16, 2009
12
0
18,520
2
Hi, last night I built a new home server, but it wont detect the HDDs from my old server, they don't even spin up.

The HDDs are Samsung 1.5tb drives (i'm not sure of the exact model as I'm at work) . The system does detect the new Crucial SSD that's plugged in.

I've tried the Samsung HDDs in my USB HDD dock plugged into my main PC and they work perfectly fine.

If I enable the storage controller 'BIOS ROM' they system locks up whilst its attempting to detect the drives. If I leave it like that for a while (~10mins) the drives spin up and start to click very loudly! I've tried putting the controller in different modes (IDE, RAID and AHCI) to no avail. I've also tried different SATA cables, SATA ports and power cables and I've updated the UEFI to the latest version. I'm going to try a different PSU powering just the HDDs this evening.

Complete system spec:
Fractal Design Node 304 Case
AsRock FM2A85X-ITX Motherboard
SanDisk SDSSDP-064G-G25 64GB SSD
2x Samsung 1.5tb HDDs
Corsair Builder Series CXM 500W Modular 80 PLUS Bronze Certified ATX/EPS PSU
G.Skill 8GB (2x 4GB) Dual Channel Ares Series Memory Kit (DDR3 1866, 9-10-9-28)
AMD A4-5300

If anyone has any ideas I would be very appreciative!

Update:

So, I've tried some more things:

3 different PSUs, all with the same outcome, HDDs not detected then after a while they start to click.

Over clocking the CPU causes the drives to be detected. I noticed there is a note in the UEFI about overclocking causing the HDDs not to be detected, so I thought i would over clock by 100mhz and see what happened. Low and behold the drives are detected. The thing is I dont want to run the system overclocked.

Different RAM, I put some Corsair DDR-1600 in (in place of the G.Skill DDR3-1866) and the system came up and detected all the drives!! I spent about 5 hours getting the OS installed and all the services and everything was great! I declared victory and moved it to its permanent home (about 4 foot from where it was). When I powered it on... the drives aren't detected and start to click! I've not managed to get it to do anything else since!

I've tried every RAM combo (stick A&B in slots 1&2, A&B in slots 2&1, A in 1, A in 2, B in 1, B in 2) no joy. I've tried every HDD & SSD combo (too many to list) all with no effect!

The SSD is always detected.



I dot know what to do now!
 

ASK THE COMMUNITY

TRENDING THREADS