ASROCK H67M doesn't boot


Sep 25, 2012
Hello, I've recently aquired an ASROCK H67M mobo that doesn't work properly or that's what i think.

Let's see...It's the 3rd time that i've got an RMA from my provider because the mobo didn't boot.

The first time I installed the motherboard with the rest of the components:

Tacens Radix V 550W
Intel Core I3 2120 3.3Ghz
Kingston HyperX Blu DDR3 1333 PC3
OCZ Vertex 3 SATA3 2.5" SSD 60GB

The thing is that after a while the system shuted down, I updated the BIOS to get the system working properly with the I3 and it worked, but then I tried to plug a simple PCIe Video Card, an Asus Radeon EAH5450 SILENT DI 1GB DDR3 and... The mess was back, the system didn't boot at all (The same video card with another mobo works fine).

I got the first RMA and they sent me a new motherboard. In order to not loose to much time I only (no cpu, no memory, nothing) plugged the power supply and switched the motherboard on to see if it worked, and it didn't.

I'm a little confused because I've done the same operation a lot of times and with other motherboards that step works fine, the power supply unit fan starts working so I start to install the rest of the system, is that correct?

I got the second RMA and...they answered me the following:

"The problem was caused by the BIOS rev, it wasn't compatible with your CPU, it has been updated so it'll work fine"

I didn't believe it, they sent me the "repaired" product and... surprise it didn't work.

So I've three questions:

1. Is there any kind of mobo that can't boot without a cpu attached?
2. If not how the hell can you update a bios in a mobo that doesn't boot?
3. Am I getting mad?

What do you think, guys?
Answers to your questions;
1) A CPU and ram is neccessary for a motherboard to POST - motherboard cannot easily be tested without them.
2) You find a processor that is supported, update BIOS with that processor installed, then use the processor you had originally intended. What if you aren't rich? - That's a different question...
3) Frustrated perhaps?