ASRock P67 Extreme 4 Gen3 won't post.


Oct 8, 2011
I recently completed a new build and everything was perfect for awhile. Tried to turn the PC on one morning and it didn't post, it hung on a 0x0D. I stripped it down and it posted fine. After a bit of trouble shooting I found that if I have my Microsoft Sidewinder X5 keyboard plugged into a USB 2.0 port, that is what hangs the MoBo. Plugged into USB 3.0 it's fine (but 3.0 doesn't have power until after system boot). I have an old IBM USB keyboard, and that does not hang the board. I've never had a stitch of problems with this keyboard before, so I can't help feeling that there's something strange going on with the board. Could it be drawing too much USB power during POST? It is fully backlit, but I don't have another backlit keyboard to test my theory. Any suggestions to try and sort it out?

My workaround is to leave the Sidewinder plugged into USB 3.0, and if I need to access BIOS or boot menu's I plug the old IBM into a FP USB 2.0 port. It works, but it's not how I want my brand new rig to behave.

Edit: Tried to put my build in my signature, but it didn't work... here's the details.

Cooler Master HAF 922 | Cooler Master Silent Pro M700W | ASRock P67 Extreme 4 Gen 3 | i5 2500K @ 4.6 Ghz | Corsair H60 Hydro Series CPU Cooler | 8 Gb Corsair Vengeance DDR3 1600 9-9-9-24 | MSI GTX570 Twin Frozr III @ 900/1800 Mhz | Crucial M4 128 Gb Sata III SSD | Samsung Spinpoint F3 1 TB Sata II HDD | Whatever I had lying around Optical Drive | Sidewinder X4/X5 Kb/Mouse