Asrock x370 sli/ac won’t post

Mar 7, 2018
1
0
10
0
First build

components:
mobo: Asrock x370 sli/ac
cpu: AMD A6 9500E ( updating to Ryzen 5 2400g after bios update)
gpu: MSI GeForce 1060 6gb gaming x
PSU: Corsair 650w 80gold
hardrive: Samsung 860 evo ssd
ram: 16gb 2400 GSkill fortis
Case: Corsair 570x
monitor: 24inch 60hrz samsung

the system currently will not post. I have checked all the cables, changed ram slots, only used 1 stick of ram, jumped the cmos, removed cmos battery, requested an RMA received new mobo tried all of this again and am still not posting. I have onboard speaker installed and have not received any beep codes.

Any my help would be apprciated
 

feelinfroggy777

Splendid
Dec 13, 2016
5,227
3
23,415
1,274
Usually when a PC wont post it is a RAM issue. Ryzen has real RAM compatibility issues and Fortis is not a very common series from GSkill. I would check the model number of the RAM on the memory QVL for the ASRock X370 board. It may not work with that board.
 
Mar 15, 2018
7
0
10
0
If you haven't figured it out yet would you happen to know what bios version you are on? if not I recommend updating the Bios to the newest version. I had a problem with mine not booting with an m.2 and a graphics card installed at the same time. this has been a pretty common issue as of late with threadripper and Ryzen.
 

cheekymonkey

Reputable
Mar 18, 2014
1
0
4,520
1

I know this is a late response, but I'm hoping it will help others. I had a b*tch of a time getting this mb to work, but now it humms.

This mb is very particular about what ram you put in it. Check Asrock's Memory QVL here to make sure that your Fortis is on the list: https://www.asrock.com/MB/Intel/Z370%20Killer%20SLIac/index.asp#Memory

Also, the latest firmware (1.6) was created to increase ram compatibility, so you might want to upgrade the firmware first and then try your ram again.

If you can't get to the bios, another trick is to put a different brand/model of ddr4 in which should tell the mb that there's a hardware change and reset, then change the settings back to default, and then try your Fortis (or the appropriate compatible ram) again. I had the same problem where I couldn't even get the bios to come up after I set XMP defaults. Nothing would work, not even bridging the pins to reset cmos. But then I put in another ram, and voila...
 

Similar threads