Question ASROCK X570 Phantom Gaming 4 SATA issue

Jun 2, 2022
3
0
10
0
Hello,

After installation of my new configuration (migration from old server), with new CPU + RAM + NVME SDD + ASROCK MoBo, one of my RAID5 arrays (5x4To HDD) went corrupted.
Rebuild was impossible and 1 HDD was systematically ejected during the process.
After inspection of logs, it appears that ata2 port is the issue. Link goes down after a few minutes (from SATA 6Go to UDMA 33, and then down)
DMSEG has the same conclusion.
HDD is not in cause, since permutating SATA ports displaces the problem to the new HDD connected to ata2 port.
I managed to rebuild my array using an additional PCIe SATA card and stopping using ata2 port.

If ata2 port is not used, there is no errors anymore in DMESG output

I bought this motherboard specifically for its 8x SATA ports and now, only 7 are usable, and more worrying, my data are note safe!
Is it a known issue? What should I do?
Thank you

Motherboard Model Name: X570 Phantom gaming 4

CPU/Processor (Brand,Speed, FSB,Cache Size): AMD RYZEN 5 5600G 3.9 GHz, 16 Mo L3
Memory (Speed, Capacity, Brand): 2x 8Go Corsair Vengeance LPX 16Go 3200 MHz
Video Card (Brand, Model, Memory size): onboard
Operating System (Loaded service pack and driver): Debian 11
Hard Drive (Brand, Model, Capacity):

- RAID5 5x4To HDD

- RAID1 2x4To HDD

- NVME Crucial CT250P5SSD8 SSD P5 250Go (OS)
 
Jun 2, 2022
3
0
10
0
of course, it is the latest available: 4.3
I finally get a feedback of Asrock support..... suggesting claiming for MB replacement :s
 
Jun 2, 2022
3
0
10
0
Hello,
I got my replacement MB yesterday
unfortunately, new board same results
after 12 hours, I again one HDD ejected (SATA LINK reset) resulting on degraded RAID array.
I moved 3 of my 8 HDD on an additional PCIe SATA card....
but it seems still to have SATA controller issues:

Code:
9.271992] ata6: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    9.274925] ata6.00: configured for UDMA/133
[    9.275020] ata6: EH complete
[    9.308000] ata6.00: exception Emask 0x10 SAct 0x80000 SErr 0x400001 action 0x6 frozen
[    9.308041] ata6.00: irq_stat 0x0c000000, interface fatal error
[    9.308052] ata6: SError: { RecovData Handshk }
[    9.308063] ata6.00: failed command: WRITE FPDMA QUEUED
[    9.308074] ata6.00: cmd 61/08:98:10:00:00/00:00:00:00:00/40 tag 19 ncq dma 4096 out
                        res 40/00:98:10:00:00/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
[    9.308104] ata6.00: status: { DRDY }
[    9.308116] ata6: hard resetting link
[    9.392067] sd 3:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[    9.787995] ata6: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    9.790843] ata6.00: configured for UDMA/133
[    9.790936] ata6: EH complete
[    9.820002] ata6: limiting SATA link speed to 3.0 Gbps
[    9.820006] ata6.00: exception Emask 0x10 SAct 0x200000 SErr 0x400001 action 0x6 frozen
[    9.820034] ata6.00: irq_stat 0x0c000000, interface fatal error
[    9.820046] ata6: SError: { RecovData Handshk }
[    9.820056] ata6.00: failed command: WRITE FPDMA QUEUED
[    9.820068] ata6.00: cmd 61/08:a8:10:00:00/00:00:00:00:00/40 tag 21 ncq dma 4096 out
                        res 40/00:a8:10:00:00/00:00:00:00:00/40 Emask 0x10 (ATA bus error)
[    9.820104] ata6.00: status: { DRDY }
[    9.820113] ata6: hard resetting link
[   10.295994] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   10.298801] ata6.00: configured for UDMA/133
[   10.298900] ata6: EH complete
What should I do next?
I saw a beta 4.35 BIOS is available, but since changelog has not SATA related points, I'm not sure it could help...
tell me if you need suppl infos
thank you
 

ASK THE COMMUNITY

TRENDING THREADS