• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Asrock X570 Phantom Gaming X not booting

May 5, 2020
Hi,i just built an entire new x570/Ryzen build but is not booting up ! I have tried everything.Everything is brand new.

The board keeps flashing the RGB LED's

Teal colour in the I/O,purple in the right edge corner and teal colour again in the Asrock logo.Between pcie connectors.

I dont see any red lights.

No power on on entire system.

Checked 10 times each plug,conectors.Still no boot up.

I was so excited but now im worried.

What it can be ????

Vic 40

If you see rgb there must be some power. Maybe make some pictures with your phone and post them here,

You can use Imgur to post a picture here,use the "img" link.
Click "new post" ->choose "upload images" -> "browse" ->choose the picture and click "open" ->put cursor on the picture that you uploaded->choose "share links" and copy the img link,paste it in your next post.
Did you breadboard before building? Try that as well if not. Make sure all power connectors are seated properly, if a modular psu on both ends.

Oh ..... and what other parts? for psu maker+model+wattage.